POJ 3252 Round Numbers (组合数学+数位dp)

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13888 Accepted: 5483

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source

USACO 2006 November Silver


利用组合数

计算满足二进制中0的个数大于1的个数的数,分两类:

(1)位数小于len时:长度为1~len-1,首位为1,所以1<=i<=len-2,j表示从i个数里取j个0,所以(i/2+1)<=j<=i,ans+=c[i][j];

(2)位数等于len时:需考虑最大上限,若第i位为1,可计算其为0的时候;若第i位为0,zero++,其影响在后几位中需取0的个数


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#define maxn 2520
typedef long long ll;
using namespace std;
int s,f,cnt;
int c[35][35];
int b[35];
void bin(int x)
{
	cnt=0;
	while(x)
	{
		b[++cnt]=x%2;
		x/=2;
	}
	return ;
}
int work(int x)
{
	int i,j,ans=0;
	bin(x);
	for(i=1;i<=cnt-2;i++)
	{
		for(j=i/2+1;j<=i;j++)
		{
			ans+=c[i][j];
		}
	}
	int z=0;
	for(i=cnt-1;i>=1;i--)
	{
		if(b[i])
		{
			for(j=(cnt+1)/2-(z+1);j<=i-1;j++)
			{
				ans+=c[i-1][j];
			}
		}
		else
			z++;
	}
	return ans;
}
int main ()
{
	int i,j;
    c[0][0]=1;
	for(i=1;i<35;i++)
	{
		c[i][1]=i;
		c[i][0]=1;
	}
	for(i=2;i<35;i++)
	{
		for(j=2;j<35;j++)
		{
			c[i][j]=c[i-1][j-1]+c[i-1][j];
		}
	}
	scanf("%d %d",&s,&f);
	printf("%d\n",work(f+1)-work(s));
	return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值