HDU 3001 Travelling (三进制状压DP)

Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7905    Accepted Submission(s): 2588


Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
  
  
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
  
  
100 90 7
 

Source
 

Recommend

gaojie


w[i][j]表示三进制状态为i时,第j位的值

dp[i][j]表示状态为i,终点为j时的the minimum fee

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#define mod 100000000
int const inf=1000000000;
using namespace std;
int dp[60000][20],w[60000][20],s[20],dis[20][20],n,m;
int main ()
{
	int i,j,k;
	s[0]=1;
	for(i=1;i<=10;i++)
		s[i]=s[i-1]*3;
	for(i=0;i<s[10];i++)
	{
		int t=i;
		for(j=0;j<10;j++)
		{
			w[i][j]=t%3;
			t/=3;
		}
	}
	int a,b,c;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		int ans=inf;
		for(i=0;i<15;i++)
			for(j=0;j<15;j++)
				dis[i][j]=inf;
		for(i=1;i<=m;i++)
		{
			scanf("%d %d %d",&a,&b,&c);
			a--;
			b--;
			dis[a][b]=dis[b][a]=min(dis[a][b],c);
		}
		for(i=0;i<s[n];i++)
			for(j=0;j<10;j++)
				dp[i][j]=inf;
		for(i=0;i<n;i++)
			dp[s[i]][i]=0;
		for(i=0;i<s[n];i++)
		{
			int flag=0;
			for(j=0;j<n;j++)
			{
				if(w[i][j]==0)
					flag=1;
				if(dp[i][j]==inf)
					continue;
				for(k=0;k<n;k++)
				{
					if(dis[j][k]==inf || w[i][k]==2)
						continue;
					int t=i+s[k];
					dp[t][k]=min(dp[t][k],dp[i][j]+dis[j][k]);
				}
			}
			if(flag==0)
			{
				for(j=0;j<n;j++)
				{
					ans=min(ans,dp[i][j]);
				}
			}
		}
		if(ans==inf)
			ans=-1; 	
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值