HDU 3709 Balanced Number (数位DP)

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 6038    Accepted Submission(s): 2887


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
  
  
2 0 9 7604 24324
 

Sample Output
  
  
10 897
 

Author
GAO, Yuan
 

Source
 

Recommend

zhengfeng


枚举支点

dp[i][j][k]表示i+1~len位数字已确定,搜索第i位数字,支点为j,力矩为k的可能性


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#define maxn 2520
typedef long long ll;
using namespace std;
ll x,y,dp[20][20][3010];
int digit[20];
ll dfs(int p,int cent,int bal,int limit)
{
	ll ans=0;
	int num,i;
	if(p==0)
		return bal==0;
	if(bal<0)
		return 0;
	if(!limit&&dp[p][cent][bal]!=-1)
		return dp[p][cent][bal];
	num=limit?digit[p]:9;
	for(i=0;i<=num;i++)
	{
		ans+=dfs(p-1,cent,bal+i*(p-cent),limit&&i==num);;
	}
	if(!limit)
		dp[p][cent][bal]=ans;
	return ans;
}
ll work(ll n)
{
	int len=0;
	while(n)
	{
		digit[++len]=n%10;
		n/=10;
	}
	int i;
	long long ans=0;
	for(i=1;i<=len;i++)
	{
		ans+=dfs(len,i,0,1);
	}
	return ans-len+1;
}
int main ()
{
	int t;
	scanf("%d",&t);
	memset(dp,-1,sizeof(dp));
	while(t--)
	{
		scanf("%lld %lld",&x,&y);
		printf("%lld\n",work(y)-work(x-1));
	}
	return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值