uva10010 - Where's Waldorf?

Given a m by n grid of letters, ( $1 \leq m,n \leq 20$), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n, $1 \leq
m,n \leq 50$ in decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on a line by itself ( $1 \leq k \leq 20$). The next k lines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output 

2 5
2 3
1 2
7 8

字符串匹配,题目说了有八个方向上下左右还有斜的,直接八个方向暴利搜索,找到之后推出循环goto语句还是比较实用的这里大笑,至于八个方向可以用方向数组存储每种方向数组下标值得变化,借助循环实现,不必自己分8种累死累活的分开做

#include <stdio.h>  
#include <string.h>  
int main() 
{char s[51][51],s1[51],x,num;
 int t,pi,pj,pos,way,n,m,i,j,k,ki,kj,l,move[8][2]={1,0,-1,0,0,1,0,-1,1,1,-1,-1,1,-1,-1,1};
 scanf("%d",&t);
 while (t--)
 {
 scanf("%d%d\n",&n,&m);
 for (i=1;i<=n;i++)
 {
  for (j=1;j<=m;j++)
  {scanf("%c",&x);
   if (x<='Z') x=x+32;
   s[i][j]=x;
  }
  getchar();
 }
 scanf("%d\n",&num);
 while (num--)
 {gets(s1);
  l=strlen(s1);
  for (i=0;i<l;i++)
  if (s1[i]<='Z') s1[i]=s1[i]+32;
  for (i=1;i<=n;i++)
  for (j=1;j<=m;j++)
  if (s[i][j]==s1[0])
  {
   for (way=0;way<8;way++)
   {pos=0;ki=i;kj=j;pi=i;pj=j;
    while ((ki>=1)&&(ki<=n)&&(kj>=1)&&(kj<=m))
 {ki=ki+move[way][0];
  kj=kj+move[way][1];
  if ((ki>=1)&&(ki<=n)&&(kj>=1)&&(kj<=m)&&(s1[pos+1]==s[ki][kj])) ++pos;
                                                            else break;
 }
 if (pos==l-1) goto there ;
   }
  
  }
  there : printf("%d %d\n",pi,pj);
 }
 if (t) printf("\n");
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值