uva 537 - Artificial Intelligence?

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on theP-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input 

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the formI=xA, U=xV or P=xW, wherex is a real number.

Directly before the unit (A, V or W) one of the prefixesm (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'

Additional assertions:

  • The equal sign (`=') will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • Either P and U, P and I, or U andI will be given.

Output 

For each test case, print three lines:

  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

Sample Input 

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output 

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V

用gets一行读入处理数据runtime error几十次;

尝试过

1开大数组

2.小数点后超过2位不计入防止越界

3P/u I分母为0的情况

还是runtime error

一下是runtime error 的一个版本求高手指教啊

#include <stdio.h>  
#include <string.h>
int main() 
{char s[10000];
 long  i,j,k,l,pos,fi,fp,fu,num,point,t;
 double P,U,I,x,y,z,w,answer;
 scanf("%ld",&t);
 getchar();
 for (k=1;k<=t;k++)
 {
  fgets(s,10000,stdin);
  l=strlen(s);
  fi=1;fu=1;fp=1;
 
  for (i=0;i<l;i++)
  if (s[i]=='=')
  {
   for (j=i+1;j<l;j++)
   if ((s[j]=='V')||(s[j]=='W')||(s[j]=='A')) {pos=j-1;break;}
  
   num=0; point=-1;  w=1;
  
   if (s[pos]=='M') {--pos;w=1000000;}
   if (s[pos]=='K') {--pos;w=1000;}
   if (s[pos]=='m') {--pos;w=0.001;}
  
   for (j=i+1;j<=pos;j++)
   {if (s[j]=='.') {point=j;break;}
    else {num=10*num+s[j]-'0';}
   }
  
   y=0;
   if (point!=-1)
  
   {if (pos-point>=3) pos=point+3;
 for (j=pos;j>point;j--)
    {z=s[j]-'0';
     y=y*0.1+z;
 }
   }
  x=num;
  x+=0.1*y;
  x=w*x;
  switch (s[i-1])
  {case 'I':I=x;fi=0;break;
   case 'P':P=x;fp=0;break;
   case 'U':U=x;fu=0;break;
  }
 }
 printf("Problem #%d\n",k);
 if (fi) {if (U==0) answer=0; else answer=P/U; printf("I=%.2lfA\n",answer);}
 if (fu) {if (I==0) answer=0; else answer=P/I; printf("U=%.2lfV\n",answer);}
 if (fp) printf("P=%.2lfW\n",U*I);
 }

错了三天了百度无数次无任何想法;

今日看见某人的做法学习了下并且给他优化了下代码好短,

大致思路就是每次出现有且仅有2个=号所以找到等号然后直接读入实数。

但是有个小问题,就是每次都是以=号作为读入结束标志,最后一组数据的第二个=号之后的字符都没读入直接输出答案了,这样也对╮(╯▽╰)╭孤陋寡闻了。

#include <stdio.h>
void main()
{char x;
 int t,i,j,k;
 double num,w,P,U,I;
 scanf("%d\n",&t);
 for (k=1;k<=t;k++)
 {
  P=0;U=0;I=0;
  for (j=0;j<2;j++)
  {while (scanf("%c",&x))
   if (x=='=') break;
   scanf("%lf%c",&num,&x);
   w=1;
   if (x=='m') {scanf("%c",&x);w=0.001;}
   if (x=='k') {scanf("%c",&x);w=1000;}
   if (x=='M') {scanf("%c",&x);w=1000000;}
   num*=w;
   if (x=='A') I=num;
   if (x=='V') U=num;
   if (x=='W') P=num;
  }
  printf("Problem #%d\n",k);
  if (I&&U) printf("P=%.2lfW\n",U*I);
  if (I&&P) printf("U=%.2lfV\n",P/I);
  if (U&&P) printf("I=%.2lfA\n",P/U);
  printf("\n");
 }
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值