Machine Schedule HDoj (二分图最小顶点覆盖--最大匹配数)

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6865    Accepted Submission(s): 3446


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.  
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3



#include<iostream>
#include<cstring>
#include<cstdio>
bool linkmap[128][128],use[128];//linkmap[][]表示链接的两个点,use[]判断集合中的点是否被用到
int cropath[128],n,m;//路径
using namespace std;
int fi(int  u)
{
    for(int i=1;i<=m;i++)
    {
        if(linkmap[u][i]&&!use[i])
        {
            use[i]=1;//标记下用到的点
            if(cropath[i]==-1||fi(cropath[i]))//如果路径即将被拓展则取反并返回
            {
                cropath[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int a,b,c,k;
    while(cin>>n&&n)
    {
        cin>>m>>k;
        memset(linkmap,false,sizeof(linkmap));
        memset(cropath,-1,sizeof(cropath));//用于判断增加路径数
        for(int i=0;i<k;i++)
        {
            cin>>a>>b>>c;
            linkmap[b][c]=true;
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            memset(use,0,sizeof(use));// 每进行一个点的查找都要清零
            if(fi(i))
            ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值