hdu4614----Vases and Flowers

Vases and Flowers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2120    Accepted Submission(s): 822


Problem Description
  Alice is so popular that she can receive many flowers everyday. She has N vases numbered from 0 to N-1. When she receive some flowers, she will try to put them in the vases, one flower in one vase. She randomly choose the vase A and try to put a flower in the vase. If the there is no flower in the vase, she will put a flower in it, otherwise she skip this vase. And then she will try put in the vase A+1, A+2, ..., N-1, until there is no flower left or she has tried the vase N-1. The left flowers will be discarded. Of course, sometimes she will clean the vases. Because there are too many vases, she randomly choose to clean the vases numbered from A to B(A <= B). The flowers in the cleaned vases will be discarded.
 

Input
  The first line contains an integer T, indicating the number of test cases.
  For each test case, the first line contains two integers N(1 < N < 50001) and M(1 < M < 50001). N is the number of vases, and M is the operations of Alice. Each of the next M lines contains three integers. The first integer of one line is K(1 or 2). If K is 1, then two integers A and F follow. It means Alice receive F flowers and try to put a flower in the vase A first. If K is 2, then two integers A and B follow. It means the owner would like to clean the vases numbered from A to B(A <= B).
 

Output
  For each operation of which K is 1, output the position of the vase in which Alice put the first flower and last one, separated by a blank. If she can not put any one, then output 'Can not put any one.'. For each operation of which K is 2, output the number of discarded flowers.
   Output one blank line after each test case.
 

Sample Input
  
  
2 10 5 1 3 5 2 4 5 1 1 8 2 3 6 1 8 8 10 6 1 2 5 2 3 4 1 0 8 2 2 5 1 4 4 1 2 3
 

Sample Output
  
  
[pre]3 7 2 1 9 4 Can not put any one. 2 6 2 0 9 4 4 5 2 3 [/pre]
 

Source
 

Recommend

线段树,维护区间空花瓶数量,查询时我们需要查询区间第一个空花瓶位置,区间最后一个空花瓶的位置,以及区间内空花瓶的数量

/*************************************************************************
    > File Name: seg_8.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月11日 星期日 16时27分59秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 50010;

struct node
{
	int l, r;
	int add;
	int cnt; //空花瓶数目
}tree[N << 2];

void pushdown (int p)
{
	if (tree[p].add != -1)
	{
		if (tree[p].add == 1)
		{
			tree[p << 1].cnt = 0;
			tree[p << 1 | 1].cnt = 0;
			tree[p << 1].add = tree[p].add;
			tree[p << 1 | 1].add = tree[p].add;
		}
		else
		{
			tree[p << 1].cnt = tree[p << 1].r - tree[p << 1].l + 1;
			tree[p << 1 | 1].cnt = tree[p << 1 | 1].r - tree[p << 1 | 1].l + 1;
			tree[p << 1].add = tree[p].add;
			tree[p << 1 | 1].add = tree[p].add;
		}
		tree[p].add = -1;
	}
}

void build (int p, int l, int r)
{
	tree[p].l = l;
	tree[p].r = r;
	tree[p].cnt = r - l + 1;
	tree[p].add = -1;
	if (l == r)
	{
		return;
	}
	int mid = (l + r) >> 1;
	build (p << 1, l, mid);
	build (p << 1 | 1, mid + 1, r);
}

void update (int p, int l, int r, int sa)
{
	if (l == tree[p].l && tree[p].r == r)
	{
		if (sa)
		{
			tree[p].cnt = 0; //放花
			tree[p].add = 1;
		}
		else
		{
			tree[p].cnt = tree[p].r - tree[p].l + 1; //取花
			tree[p].add = 0;
		}
		return;
	}
	pushdown (p);
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (r <= mid)
	{
		update (p << 1, l, r, sa);
	}
	else if (l > mid)
	{
		update (p << 1 | 1, l, r, sa);
	}
	else
	{
		update (p << 1, l, mid, sa);
		update (p << 1 | 1, mid + 1, r, sa);
	}
	tree[p].cnt = tree[p << 1].cnt + tree[p << 1 | 1].cnt;
//	printf("区间[%d, %d] 有 %d 个 空花瓶\n", tree[p].l, tree[p].r, tree[p].cnt);
}

int query_num (int p, int l, int r)
{
	if (l == tree[p].l && r == tree[p].r)
	{
		return tree[p].cnt;
	}
	pushdown (p);
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (r <= mid)
	{
		return query_num (p << 1, l, r);
	}
	else if (l > mid)
	{
		return query_num (p << 1 | 1, l, r);
	}
	else
	{
		return query_num (p << 1, l, mid) + query_num (p << 1 | 1, mid + 1, r);
	}
}

int dfs (int p, int l, int r, int x)
{
	if (tree[p].l == tree[p].r)
	{
		return tree[p].l;
	}
	pushdown (p);
	int mid = (tree[p].l + tree[p].r) >> 1;
	if (r <= mid)
	{
		return dfs (p << 1, l, r, x);
	}
	else if (l > mid)
	{
		return dfs (p << 1 | 1, l, r, x);
	}
	else
	{
		int cnt = query_num (1, l, mid);
		if (cnt >= x)
		{
			return dfs (p << 1, l, mid, x);
		}
		else
		{
			return dfs (p << 1 | 1, mid + 1, r, x - cnt);
		}
	}
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int n, m, k, x, f;
		scanf("%d%d", &n, &m);
		build (1, 0, n - 1);
		while (m--)
		{
			scanf("%d%d%d", &k, &x, &f);
			if (k == 2)
			{
				int cnt = query_num (1, x, f);
				printf("%d\n", f - x + 1 - cnt);
				update (1, x, f, 0);
			}
			else
			{
				int cnt = query_num (1, x, n - 1);
				if (cnt == 0)
				{
					printf ("Can not put any one.\n");
					continue;
				}
				int s = dfs (1, x, n - 1, 1);
				if (cnt >= f)
				{
					int e = dfs(1, x, n - 1, f);
					printf("%d %d\n", s, e);
					update (1, s, e, 1);
				}
				else
				{
					int e = dfs(1, x, n - 1, cnt);
					printf("%d %d\n", s, e);
					update (1, s, e, 1);
				}
			}
		}
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值