acm UVA 227 Puzzle字符串处理

A children's puzzle that was popular 30 years ago consisted of a 5
5 frame which contained 24 small
squares of equal size. A unique letter of the alphabet was printed on each small square. Since there
were only 24 squares within the frame, the frame also contained an empty position which was the same
size as a small square. A square could be moved into that empty position if it were immediately to the
right, to the left, above, or below the empty position. The object of the puzzle was to slide squares
into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original con guration and in its con guration after
the following sequence of 6 moves:
1) The square above the empty position moves.
2) The square to the right of the empty position moves.
3) The square to the right of the empty position moves.
4) The square below the empty position moves.
5) The square below the empty position moves.
6) The square to the left of the empty position moves.
Write a program to display resulting frames given their initial con gurations and sequences of moves.
Input
Input for your program consists of several puzzles. Each is described by its initial con guration and
the sequence of moves on the puzzle. The rst 5 lines of each puzzle description are the starting
con guration. Subsequent lines give the sequence of moves.
The rst line of the frame display corresponds to the top line of squares in the puzzle. The other
lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains
exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost
square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square
moves into the empty position. A denotes that the square above the empty position moves; B denotes
that the square below the empty position moves; L denotes that the square to the left of the empty
position moves; R denotes that the square to the right of the empty position moves. It is possible that
there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move
occurs, the puzzle is considered to have no nal con guration. This sequence of moves may be spread
over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
Output
Output for each puzzle begins with an appropriately labeled number (
Puzzle #1
,
Puzzle #2
, etc.). If
the puzzle has no nal con guration, then a message to that effect should follow. Otherwise that nal
con guration should be displayed.
Format each line for a nal con guration so that there is a single blank character between two
adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior
position, then it will appear as a sequence of 3 blanks | one to separate it from the square to the left,
one for the empty position itself, and one to separate it from the square to the right.
Separate output from different puzzle records by one blank line.
Note:
The rst record of the sample input corresponds to the puzzle illustrated above.
Sample Input
TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAAAABBRRRLL0
Z
Sample Output
Puzzle #1:
T R G S J
X O K L I
M D V B N
W P A E
U Q H C F
Puzzle #2:
A B C D
F G H I E
K L M N J
P Q R S O
T U V W X
Puzzle #3:

This puzzle has no final configuratio




比较特殊的就是输入的指令可能是有换行



如:AB
        LL
       RR0

加上空格就好了

#include<bits/stdc++.h>
using namespace std;
char a[7][7];
int sx,sy;
bool mov(char x)
{
    if(x=='A')
    {
        if(sx>0){
            a[sx][sy]=a[sx-1][sy];sx--;a[sx][sy]=' ';return true;
        }
        else return false;
    }
    if(x=='B')
    {
        if(sx<4){
            a[sx][sy]=a[sx+1][sy];sx++;a[sx][sy]=' ';return true;
        }
        else return false;
    }
    if(x=='L')
    {
        if(sy>0){
            a[sx][sy]=a[sx][sy-1];sy--;a[sx][sy]=' ';return true;
        }
        else return false;
    }
    if(x=='R')
    {
        if(sy<4){
            a[sx][sy]=a[sx][sy+1];sy++;a[sx][sy]=' ';return true;
        }
        else return false;
    }
    return false;
}
int main()
{
    int cnt=0;
    gets(a[0]);
    while(strcmp(a[0],"Z")!=0)
    {
        for(int i=1;i<5;i++)
            gets(a[i]);
        for(int i=0;i<5;i++)
            for(int j=0;j<5;j++)
            if(a[i][j]==' ')sx=i,sy=j;
        if(cnt==0)printf("Puzzle #%d:\n",++cnt);
        else printf("\nPuzzle #%d:\n",++cnt);
        char ch;
        int flag=0;
        scanf(" %c",&ch);
        while(ch!='0')
        {
            if(!mov(ch)){flag=1;}
            scanf(" %c",&ch);
        }
        if(flag==0){
            for(int i=0;i<5;i++)
            {
                for(int j=0;j<5;j++){
                    if(j==0)printf("%c",a[i][j]);
                    else printf(" %c",a[i][j]);
                }
                printf("\n");
            }
        }
        else printf("This puzzle has no final configuration.\n");
        getchar();
        gets(a[0]);
    }
    return 0;
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值