HDU 2614 Beat

Beat

                                                                       Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                        Total Submission(s): 1127    Accepted Submission(s): 681


Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
 

Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
 

Output
For each test case output the maximum number of problem zty can solved.


 

Sample Input
  
  
3 0 0 0 1 0 1 1 0 0 3 0 2 2 1 0 1 1 1 0 5 0 1 2 3 1 0 0 2 3 1 0 0 0 3 1 0 0 0 0 2 0 0 0 0 0
 

Sample Output
  
  
3 2 4
Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.
 

Author
yifenfei
 

Source
 
题目链接:
http://acm.hdu.edu.cn/showproblem.php?pid=2614

题意:有 n 个问题,T[ i ][ j ] 表示解决第 i 个问题后再解决第 j 个问题所花的时间

他有一个好习惯,解决后面的问题花费的时间都不能比前一个问题花的时间少

即要解决第 i,j,k 这三个问题需满足 T[ i ][ j ] <= T[ j ][ k ]

dfs

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int Max, n;
int vis[20], Time[20][20];

void dfs(int id, int t, int cnt) //解决了第 id 个问题,花费了 t 时间, 当前共解决cnt个问题
{
    if (cnt > Max)
        Max = cnt;

    for (int i = 1; i < n; i++)         //查找还能解决的问题
        if (!vis[i] && Time[id][i] >= t)    //如果第 i 个问题还未解决,且满足条件
        {
            vis[i] = 1;                     //解决第 i 个问题,标记
            dfs(i, Time[id][i], cnt + 1);   //继续往后搜索
            vis[i] = 0;                     //搜索完后清除标记
        }
}
int main()
{

    while (~scanf("%d", &n))
    {
        for (int i = 0; i < n; i++)
            for (int j = 0; j < n; j++)
                scanf("%d", &Time[i][j]);
        memset(vis, 0, sizeof(vis));
        Max = 0;
        dfs(0, 0, 1);
        printf("%d\n", Max);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值