POJ 3132 Sum of Different Primes

题目大意:输入n,k,要求你找出k个和为n的不相同的素数,求可行的方案数。。。

 

Description

A positive integer may be expressed as a sum of different prime numbers (primes), in one way or another. Given two positive integersn and k, you should count the number of ways to express n as a sum ofk different primes. Here, two ways are considered to be the same if they sum up the same set of the primes. For example, 8 can be expressed as 3 + 5 and 5 + 3 but the are not distinguished.

When n and k are 24 and 3 respectively, the answer is two because there are two sets {2, 3, 19} and {2, 5, 17} whose sums are equal to 24. There are not other sets of three primes that sum up to 24. Forn = 24 and k = 2, the answer is three, because there are three sets {5, 19}, {7, 17} and {11, 13}. Forn = 2 and k = 1, the answer is one, because there is only one set {2} whose sum is 2. Forn = 1 and k = 1, the answer is zero. As 1 is not a prime, you shouldn’t count {1}. Forn = 4 and k = 2, the answer is zero, because there are no sets of two different primes whose sums are 4.

Your job is to write a program that reports the number of such ways for the givenn and k.

Input

The input is a sequence of datasets followed by a line containing two zeros separated by a space. A dataset is a line containing two positive integersn and k separated by a space. You may assume that n ≤ 1120 andk ≤ 14.

Output

The output should be composed of lines, each corresponding to an input dataset. An output line should contain one non-negative integer indicating the number of the ways forn and k specified in the corresponding dataset. You may assume that it is less than 231.

Sample Input

24 3 
24 2 
2 1 
1 1 
4 2 
18 3 
17 1 
17 3 
17 4 
100 5 
1000 10 
1120 14 
0 0

Sample Output

2 
3 
1 
0 
0 
2 
1 
0 
1 
55 
200102899 
2079324314
 
 
 
/*一开始想用搜索做来着,可惜没成功。。。。。。*/

#include<stdio.h>

#define M 1125

int prime[M]={2,3,5,7,11};
__int64 dp[M][50];
int num=5;

int judge(int n){
	int i,j;
	for(i=0;prime[i]*prime[i]<=n;i++){
		if(n%prime[i]==0) return 0;
	}
	return 1;
}

void Init(){
	int gab,i,j;
	for(gab=2,i=13;i<M;i+=gab){
		gab=6-gab;
		if(judge(i)) {
			//printf("%d==%d\n",num,i);
			prime[num++]=i;
		}
	}
}

int main(){
	int i,j,k;
	int sum,n;
	Init();
	dp[0][0]=1;  /*习惯性地都会输入一个处理一个。。嗯嗯。。借鉴了别人的~很不错的提前处理~~~*/
	for(i=0;i<num;i++){  /*if写成:(i=0;i<=num;i++)  就 WA了。。额。。太低级的错误了!!!因为num是个数,prime[num]==0啊!!!!!!*/
		for(j=M;j>=prime[i];j--){
			for(k=15;k>0;k--){
				dp[j][k]+=dp[j-prime[i]][k-1];
			}
		}
	}
	while(scanf("%d%d",&sum,&n),sum+n){
		printf("%I64d\n",dp[sum][n]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值