POJ 3175 Finding Bovine Roots

 

 

题目大意:输入一个L,接下来是一个L位的整数,代表一个数N的前L位小数,当然,排除完全平方数,求N。。。

之前用int取整数部分居然超时了。。。。。改用floor——16MS 过了。。。差距真大。。。

 

Description

The cows are trying to find their roots. They are not so smart as humans when they find square roots, the cows lose the integer portion of their square root calculation. Thus, instead of calculating the square root of 2 to be 1.414213562373095048801688 7242096980785696, they deduce that it is 0.414213562373095048801688 7242096980785696. The square root of 16 is calculated to be 0 (obviously an error).

The erroneous ciphering does, however, lead to an interesting question. Given a string of digits of length L (1 <= L <= 9), what is the smallest integer whose bovine square root decimal part begins with those digits?

By way of example, consider the string "123". The square root of 17 is approximately 4.123105625617660549821409 8559740770251472 so the bovine square root is: 0.123105625617660549821409 8559740770251472 whose decimal part (just after the period) starts with 123. It turns out that 17 is the smallest integer with this property.

Input

Line 1: A single integer, L

Line 2: L digits (with no spaces)

Output

Line 1: A single integer that is the smallest integer whose bovine square root starts with the supplied string

Sample Input

3 123

Sample Output

17
 Explanation of the sample:
sqrt(17) ~= 4.123105625617660549821409 8559740770251472
 
/*eps 用于解决9,99,999……的情况*/
#include<stdio.h>
#include<math.h>
#define eps 1e-8

double a[11]={1,1e-1,1e-2,1e-3,1e-4,1e-5,1e-6,1e-7,1e-8,1e-9,1e-10};

int main(){
	int n;
	int m;
	double p,q,x,y;
	while(scanf("%d",&n)!=EOF){
		scanf("%d",&m);
		p=m*a[n];  q=(m+1)*a[n];
		x=y=0;
		while(x==y){
			p+=1; q+=1;
			x=floor(p*p);  y=floor(q*q-eps);
		}
		printf("%.f\n",floor(y));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值