hdu 1455 Sticks DFS 又是一个花样剪枝 ,累觉不爱

154 篇文章 1 订阅
33 篇文章 0 订阅

Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6750    Accepted Submission(s): 1967


Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
 

Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
 

Output
The output file contains the smallest possible length of original sticks, one per line.
 

Sample Input
  
  
9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0
 

Sample Output
  
  
6 5

这题TLE了N次,也WA了很多次,算是长教训了
贴两份代码吧
别问我为什么,有代码人性!

 代码:
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std ;

int n , d[70] , t;
bool visited[70] , notPrime[65*55];

bool cmp(const int a , const int b)
{
	return a>b ;
}

bool dfs(int len , int sum , int c , int pos)
{
	if(c == t)
	{
		return true ;
	}
	else if(len == sum)
	{
		if(dfs(len,0,c+1,0))
		{
			return true ;
		}
	}
	else
	{
		for(int i = pos ; i < n ; ++i)
		{
			if(!visited[i])
			{
				if(sum+d[i]>len)
				{
					continue ;
				}
				visited[i] = true ;
				if(dfs(len,sum+d[i],c,i+1))
				{
					return true ;
				}
				visited[i] = false ;
				//这一步剪枝很重要 ,没有可能超时 
				if(sum == 0)
				{
					return false ;
				}
				//如果下一个 长度与当前相等,那无需再次重复搜索 
				while(d[i] == d[i+1])	++i ;
			}
		}
	}
	return false ;
}

int main()
{
	while(~scanf("%d",&n) && n)
	{
		int sum = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&d[i]) ;
			sum += d[i] ;
		}
		bool flag = false ;
		sort(d,d+n,cmp) ;
		for(int i =  d[0]; i <= sum/2 ; ++i)
		{
			if(sum%i == 0)		//剪枝,当且仅当sum能整除i时,才有可能 
			{
				t = sum/i ;
				memset(visited,false,sizeof(visited)) ;
				if(dfs(i,0,1,0))
				{
					printf("%d\n",i) ;
					flag = true ;
					break ;
				}
			}
		}
		if(!flag)
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}

代码:
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std ;

int n , d[70] ;
bool visited[70] , notPrime[65*55];

bool cmp(const int a , const int b)
{
	return a>b ;
}

bool dfs(int len , int sum , int c , int pos)
{
	if(c == n)
	{
		return true ;
	}
	else if(len == sum)
	{
		if(dfs(len,0,c,0))
		{
			return true ;
		}
	}
	else
	{
		for(int i = pos ; i < n ; ++i)
		{
			if(!visited[i])
			{
				if(sum+d[i]>len)
				{
					continue ;
				}
				visited[i] = true ;
				if(dfs(len,sum+d[i],c+1,i+1))
				{
					return true ;
				}
				visited[i] = false ;
				//这一步剪枝很重要 ,没有可能超时 
				if(sum == 0)
				{
					return false ;
				}
				//如果下一个 长度与当前相等,那无需再次重复搜索 
				while(d[i] == d[i+1])	++i ;
			}
		}
	}
	return false ;
}

int main()
{
	while(~scanf("%d",&n) && n)
	{
		int sum = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&d[i]) ;
			sum += d[i] ;
		}
		bool flag = false ;
		sort(d,d+n,cmp) ;
		for(int i =  d[0]; i <= sum/2 ; ++i)
		{
			if(sum%i == 0)		//剪枝,当且仅当sum能整除i时,才有可能 
			{
				memset(visited,false,sizeof(visited)) ;
				if(dfs(i,0,1,0))
				{
					printf("%d\n",i) ;
					flag = true ;
					break ;
				}
			}
		}
		if(!flag)
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}

与君共勉

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值