hdu 1455 (DFS+剪枝)

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero. 
Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero. 
Output
The output file contains the smallest possible length of original sticks, one per line. 
Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output
6
5


贪心是过不去的。只有DFS+剪枝才能过


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(i,j,k) for(int i=j; i<k; i++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define ll long long
using namespace std;
const int mod=1e9+7;
char s[2100];
int bk[110],f[50000];
ll n,m,k,minn,maxx,ans,cur,sum,x,y;
int nex[4][2]={0,1,1,0,0,-1,-1,0};
int a[100];
int dfs(int sum,int cur,int k,int pos){
    if(cur==n){
        if(!sum)return 1;
        else return 0;
    }
    for(int i=pos;i>=0;i--){
        if(!bk[i]){
            if(sum+a[i]<=k){

              bk[i]=1;
              if(sum+a[i]<k){
                      if(dfs(sum+a[i],cur+1,k,i-1))return 1;
              }
              else {
                      if(dfs(0,cur+1,k,n-1))return 1;
              }
              bk[i]=0;
              if(sum==0)return 0;
              while(i>0&&a[i]==a[i-1])i--;
            }
        }
    }
    return 0;
}
int main()
{
    while(cin>>n&&n){
        int l=0,r=0;
        rep(i,0,n)scanf("%d",a+i),l=max(l,a[i]),r+=a[i];
        rep(i,l,r+1){
           mem(bk,0);
           if(r%i==0&&dfs(0,0,i,n-1)){
              cout<<i<<endl;break;
           }
        }
    }


    return 0;
}
//freopen("C:\\Users\\LENOVO\\Desktop\\read.txt","r",stdin);



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值