hdu--5621

KK's Point

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 442    Accepted Submission(s): 148


Problem Description
Our lovely KK has a difficult mathematical problem:He points  N(2N105)  points on a circle,there are all different.Now he's going to connect the  N  points with each other(There are no three lines in the circle to hand over a point.).KK wants to know how many points are there in the picture(Including the dots of boundary).
 

Input
The first line of the input file contains an integer  T(1T10) , which indicates the number of test cases.

For each test case, there are one lines,includes a integer  N(2N105) ,indicating the number of dots of the polygon.
 

Output
For each test case, there are one lines,includes a integer,indicating the number of the dots.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
3 5
 

Source
 
解体思路:在圆上画出n个点,每个点两两相连, 在圆内没有三条直线相交成的点,但在圆上可以,问包括圆上n个点,一共有多少个交点,这肯定是一个规律题,.当n>=4时,圆内才会出现交点,可以通过画图发现,圆内每一个不同的交点都由一个不同的四边形得到,而四边形的顶点,都来自所给的n个顶点.所以当年n>=4时,交点数为Cn4+n.否则为n.这题中注意取值范围,以unsigned long long int 输出,long long 会wa.
代码如下:
#include<stdio.h>
#include<string.h>
#define llu unsigned long long int
int main()
{
    int t;
    llu m,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%llu",&n);
        if(n==2||n==3){
        	printf("%llu\n",n);
        	continue;
        }
        m=n*(n-1)/2*(n-2)/3*(n-3)/4;//每二个连续数 中一个是偶数,每3个连续数中一个3的倍数..... 
        printf("%llu\n",m+n);
    }
    return 0;
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值