hdu 5621 KK's Point【思维】

KK's Point

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 269    Accepted Submission(s): 93


Problem Description
Our lovely KK has a difficult mathematical problem:He points N(2N105) points on a circle,there are all different.Now he's going to connect the N points with each other(There are no three lines in the circle to hand over a point.).KK wants to know how many points are there in the picture(Including the dots of boundary).
 


Input
The first line of the input file contains an integer T(1T10) , which indicates the number of test cases.

For each test case, there are one lines,includes a integer N(2N105) ,indicating the number of dots of the polygon.
 


Output
For each test case, there are one lines,includes a integer,indicating the number of the dots.
 


Sample Input
  
  
2 3 4
 


Sample Output
  
  
3 5


题目大意:

在一个圆上点下n个点,问在圆内能够组成多少个交点(圆上的点也包括)、这里思路很好形成:

在圆上点下1个点的时候输出1

在圆上点下2个点的时候输出2

在圆上点下3个点的时候输出3

在圆上点下4个点的时候输出5

因为呢,只有点上4个点的时候才能在园内出现一个交点,

那么在圆上点下5个点的时候呢?思路很简单:从5个点中不断的选出4个点就能够组成一个交点,那么就是CN4、

所以最终结果就是CN-4 4

这里直接上代码:

#include<stdio.h>
#include<string.h>
using namespace std;
#define llu unsigned long long int//数据较大,ll会wa、
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        llu n;
        scanf("%I64u",&n);
        llu output=n;
        if(n==0||n==1||n==2||n==3)
        {
            printf("%I64u\n",output);
            continue;
        }
        else
        {
            output+=n*(n-1)/2*(n-2)/3*(n-3)/4;
            printf("%I64u\n",output);
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值