hdu-1220(数学规律)

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1728    Accepted Submission(s): 1373


Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.
 

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 

Output
For each test case, you should output the number of pairs that was described above in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
0 16 297
题目大意:给你一个边长为n的立方体,把它切割成单位立方体,任意两个立方体的公共点只有0或2或4,问公共点小于或等于2的立方体有多少对
解题思路:一个单位立方体,和它公共点为4 的立方体只存在三个方向。求出每个方向公共点为4 的立方体对数,相加后(X),总对数-X则为答案。然而我们可以观察出每个方向上能找到的对数是一样的,为(n-1)(n*n)
代码如下:
#include<stdio.h>
int main(){
	int n;
	long long ans;
	while(scanf("%d",&n)!=EOF){
		ans=n*n*n*(n*n*n-1)/2-3*n*n*(n-1);
		printf("%lld\n",ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值