HDU:1220 Cube(数学)

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1771    Accepted Submission(s): 1405


Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.
 

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 

Output
For each test case, you should output the number of pairs that was described above in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
0 16 297
Hint
Hint
The results will not exceed int type.
 

Author
Gao Bo
 

Source
 

Recommend
题目大意:给你个边长为n的立方体,把他切成单位立方体,求这些立方体中每两个立方体的公共顶点数小于等于2的立方体对数。
思考:切割后,这些立方体两两间的公共顶点数可能为0、1、2、4。要求小于等于二的,不如求公共顶点数为4的立方体对数,然后用总的立方体对数减去求出的 公共顶点数为4的立方体对数,即可解答。
公共点为4的对数:一列有n-1对(n个小方块,相邻的两个为一对符合要求),一个面的共有 n^2列,所以从底面、左面和前面三个方向看(切换视角)(上面、右面、后面重复,不考虑),故总数为:3*n^2(n-1)
所以结果为:n^3 * (n^3-1) - 3*n^2(n-1)




代码如下:

#include <stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int k=n*n*n;
		int zongshu=k*(k-1)/2;//总对数(组合公式) 
		int si=3*n*n*(n-1);//有四个公共点的立方体对数 
		int jieguo=zongshu-si;
		printf("%d\n",jieguo);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值