HDU 2147-kiki's game(博弈/找规律)

15 篇文章 0 订阅

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 9174    Accepted Submission(s): 5485


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
  
  
5 3 5 4 6 6 0 0
 

Sample Output
  
  
What a pity! Wonderful! Wonderful!
 

Author
月野兔
 

Source
 

Recommend
威士忌

题目意思:

有一个n*m的棋盘,从右上角的位置走到左下角的位置,每次只能向左、下和左下三个方向移动。

最后不能再移动的人输掉比赛,如果kiki赢,输出"Wonderful!";反之,输出"What a pity!"

就这道题而言,最后走到左下角位置的人为输掉比赛。


解题思路:

刚刚看了这个文件→传送门

学了一点:

必败点(P点) : 前一个选手(Previous player)将取胜的位置称为必败点。
必胜点(N点) : 下一个选手(Next player)将取胜的位置称为必胜点。

步骤1:将所有终结位置标记为必败点(P点);
步骤2: 将所有一步操作能进入必败点(P点)的位置标记为必胜点(N点)
步骤3:如果从某个点开始的所有一步操作都只能进入必胜点(N点) ,则将该点标记为必败点(P点) ;
步骤4: 如果在步骤3未能找到新的必败(P点),则算法终止;否则,返回到步骤2。
如图:

通过观察对角线和其他m或n为偶数时,N的位置,可以发现:如果n或m中有一个是偶数,那么必胜;反之,必败。


#include<iostream>
using namespace std;

int main()
{
    int n,m;
    while(cin>>n>>m&&(m||n))
    {
        if(n%2==0||m%2==0)cout<<"Wonderful!"<<endl;
        else cout<<"What a pity!"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值