HDU 2147-kiki's game

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 11339    Accepted Submission(s): 6871


题目链接:点击打开链接



Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".


Sample Input
5 3
5 4
6 6
0 0
 


Sample Output
What a pity!
Wonderful!
Wonderful!


题意:给你一个n*m的棋盘,起始位置在棋盘的右上角,然后可以往左往下往左下三个方向走,kiki先走,直到走到棋盘的左下角为止,最后走不了的玩家输,也就是走到左下角的玩家赢。


分析:本题是一个简单的博弈题,由PN图可知,n和m都为奇数时,kiki会输,其余情况他都会赢。





#include <iostream>
#include<stdio.h>
#include<cmath>
using namespace std;

int main()
{
   int n,m;
   while(scanf("%d %d",&n,&m))
   {
       if(n==0&&m==0)
            break;
       if(n%2==1&&m%2==1)
            printf("What a pity!\n");
       else
            printf("Wonderful!\n");
   }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值