POJ 3169-Layout(差分约束系统-入门裸题)

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10125 Accepted: 4874

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source


题目意思:

有编号为1~N的N头母牛,多个母牛的坐标位置可能相同。
有ML对母牛相互喜欢,A对B的距离不能大于D;
有MD对母牛相互嫌弃, A对B的距离不能小于D;
求第1头与第N头母牛之间的最大距离;如果不存在,输出“-1”;如果距离无约束,输出“-2”。

解题思路:

红果果的差分约束系统的裸题。
Db-Da≤d,则a~b权值为d;
Db-Da≥d,转化成Da-Db≤-d,则b~a权值为-d。
建一个有向图,喜欢那么距离为正,嫌弃的话距离为负。
直接SPFA求解dist[n]即1~N奶牛的距离。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <iomanip>
#include <algorithm>
#define MAXN 10010
#define INF 0xfffffff
using namespace std;

struct ArcNode
{
    int to;
    int weight;
    ArcNode *next;
};
queue<int> Q;//队列中的节点为顶点序号
int n;//顶点个数
ArcNode * List[MAXN];//每个顶点的边链表表头指针
int inq[MAXN];//每个顶点是否在队列中的标志
int dist[MAXN],path[MAXN];
int cnt[MAXN];
bool SPFA(int src)
{
    memset(cnt,0,sizeof(cnt));
    memset(inq,0,sizeof(inq));
    int i,u;//u为队列头顶点序号
    ArcNode * temp;
    for(i=1; i<=n; ++i)//初始化
    {
        dist[i]=INF;
        path[i]=src;
        inq[i]=0;
    }
    dist[src]=0;
    path[src]=src;
    ++inq[src];
    Q.push(src);
    ++cnt[src];
    while(!Q.empty())
    {
        u=Q.front();
        Q.pop();
        --inq[u];
        if(cnt[u]>n) return true;//存在负权回路
        temp=List[u];
        while(temp!=NULL)
        {
            int v=temp->to;
            if(dist[v]>dist[u]+temp->weight)
            {
                dist[v]=dist[u]+temp->weight;
                if(!inq[v])
                {
                    Q.push(v);
                    ++inq[v];
                    ++cnt[v];
                }
            }
            temp=temp->next;
        }
    }
    return false;
}
int main()
{
    int a,b;
    int u,v,w;
    cin>>n>>a>>b;
    memset(List,0,sizeof(List));
    ArcNode *temp;
    while(!Q.empty()) Q.pop();
    while(a--)
    {
        cin>>u>>v>>w;
        temp=new ArcNode;
        temp->to=v;//构造邻接表
        temp->weight=w;
        temp->next=NULL;
        if(List[u]==NULL) List[u]=temp;
        else
        {
            temp->next=List[u];
            List[u]=temp;
        }
    }
    while(b--)//负权路
    {
        cin>>u>>v>>w;
        temp=new ArcNode;
        temp->to=u;//构造邻接表
        temp->weight=-w;
        temp->next=NULL;
        if(List[v]==NULL) List[v]=temp;
        else
        {
            temp->next=List[v];
            List[v]=temp;
        }
    }
    bool flag=SPFA(1);//求源点到其他顶点的最短路径
    /*for(i=0; i<=n; ++i)
        cout<<dist[i]<<" ";
    cout<<endl;*/
    if(flag) puts("-1");//存在负环
    else
    {
        if(dist[n]==INF) puts("-2");//1~N未更新说明木有约束
        else cout<<dist[n]<<endl;
    }
    return 0;
}
/*
4 2 1
1 3 10
2 4 20
2 3 3
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值