POJ 3169-Layout(SPFA差分约束系统裸题)

Layout

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14193 Accepted: 6820

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

USACO 2005 December Gold

[Submit]   [Go Back]   [Status]   [Discuss]

题目大意:有n头牛,编号为1~n,某些牛之间有一些约束条件,ML:牛A与牛B之间的距离最多为C,MD:牛A与牛B之间的距离至少为C,如果不存在一个牛的排列使得所有的条件都满足则输出“-1”,如果牛1和牛n的距离可以无限大则输出“-2”,否则满足排列的牛1与牛n之间最大距离。

解题思路:牛都在一条直线上,所以我们设牛1的位置为x=0,对于ML:我们可以得出 (编号)max(A, B) - min(A, B) <= C(距离),对于MD:我们可以得出max(A, B) - min(A, B) >= C,即min(A, B) - max(A, B) <= -C,这样我们就得到了一个差分约束的条件,然后我们就可以用为一个最短路来求解啦!对于第一个条件,我们建一条小编号到大编号的权值为C的边,对于条件2我们建一条从大编号到小编号,权值为 - C的边,最后SPFA跑一遍1到n的最短路即可,如果存在负环则无解“-1”,如果距离无限大则“-2”,否则输出距离。

不懂差分约束系统的同学千万不要戳这里:最详细的差分约束系统

AC代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
#include<math.h>
#include<cstdlib>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#include<stack>
#define bug printf("*********\n");
#define mem0(a) memset(a, 0, sizeof(a));
#define mem1(a) memset(a, -1, sizeof(a));
#define finf(a, n) fill(a, a+n, INF);
#define in1(a) scanf("%d" ,&a);
#define in2(a, b) scanf("%d%d", &a, &b);
#define in3(a, b, c) scanf("%d%d%d", &a, &b, &c);
#define out1(a) printf("%d\n", a);
#define out2(a, b) printf("%d %d\n", a, b);
#define pb(G, b) G.push_back(b);
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
typedef long long LL;
typedef pair<LL, pair<int, LL> > LLppar;
typedef pair<double, int> dpar;
typedef pair<int, int> par;
typedef pair<LL, int> LLpar;
const LL mod = 1e9+7;
const int INF = 0x3f3f3f3f;
const int N = 1010;
const double pi = 3.1415926;

using namespace std;

int n, ml, md, cnt;
int head[1010], inq[1010], d[1010], vis[1010];

struct edge
{
    int to;
    int len;
    int next;
}e[20010];

void add(int u, int v, int w)
{
    e[cnt].to = v;
    e[cnt].len = w;
    e[cnt].next = head[u];
    head[u] = cnt ++;
}

bool spfa()
{
    for(int i = 1; i <= n; i ++) d[i] = INF;
    d[1] = 0;
    queue<int> q;
    q.push(1);
    while(!q.empty()) {
        int u = q.front();
        q.pop();
        inq[u] = 0;
        vis[u] ++;
        for(int i = head[u]; i != -1; i = e[i].next) {
            int en = e[i].to;
            int len = d[u] + e[i].len;
            if(d[en] > len) {
                d[en] = len;
                if(!inq[en]) {
                    q.push(en);
                    inq[en] = 1;
                    if(vis[en] == n) return false;
                }
            }
        }
    }
    return true;
}

void init()
{
    mem1(head);
    mem0(vis);
    mem0(inq);
    cnt = 0;
}

int main()
{
    int x, y, z;
    while(~scanf("%d%d%d", &n, &ml, &md)) {
        init();
        for(int i = 0; i < ml ; i ++) {
            scanf("%d%d%d", &x, &y, &z);
            add(min(x, y), max(x, y), z);
        }
        for(int i = 0; i < md; i ++) {
            scanf("%d%d%d", &x, &y, &z);
            add(max(x, y), min(x, y), -z);
        }
        if(!spfa()) printf("-1\n");
        else if(d[n] == INF) printf("-2\n");
        else printf("%d\n", d[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值