HDU 5874-Friends and Enemies(n个结点的无三元环的图的最大边数)

25 篇文章 1 订阅

Friends and Enemies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 292    Accepted Submission(s): 161


Problem Description
On an isolated island, lived some dwarves. A king (not a dwarf) ruled the island and the seas nearby, there are abundant cobblestones of varying colors on the island. Every two dwarves on the island are either friends or enemies. One day, the king demanded that each dwarf on the island (not including the king himself, of course) wear a stone necklace according to the following rules:
  
  For any two dwarves, if they are friends, at least one of the stones from each of their necklaces are of the same color; and if they are enemies, any two stones from each of their necklaces should be of different colors. Note that a necklace can be empty.
  
  Now, given the population and the number of colors of stones on the island, you are going to judge if it's possible for each dwarf to prepare himself a necklace.
 

Input
Multiple test cases, process till end of the input. 
  
  For each test case, the one and only line contains 2 positive integers  M,N (M,N<231)  representing the total number of dwarves (not including the king) and the number of colors of stones on the island.
 

Output
For each test case, The one and only line of output should contain a character indicating if it is possible to finish the king's assignment. Output ``T" (without quotes) if possible, ``F" (without quotes) otherwise.
 

Sample Input
      
      
20 100
 

Sample Output
      
      
T
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5877  5876  5875  5874  5872 
 

题目意思:

nnn个人, mmm种颜色的石头, 人两两之间要么是朋友, 要么是敌人. 每个人可以携带若干种石头或者不带, 要求朋友之间至少携带一种颜色相同的石头, 敌人之间不能携带有相同颜色的石头. 问最坏情况下, mmm种颜色是否够.

解题思路:

n个点的图, 要求有尽量多的边, 并且不存在三元环. 这个边数就是mmm的下界.

对于一个nnn个结点的没有三元环的图, 边数最大的就是完全二分图. 于是答案就是⌊n2⌋⋅⌈n2⌉\lfloor \frac{n}{2} \rfloor \cdot \lceil\frac{n}{2} \rceil2n2n.

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 20010
using namespace std;
int main()
{
    long long m,n;
    while(scanf("%I64d%I64d",&m,&n)!=EOF)
    {
        long long ans=floor(m/2.0)*ceil(m/2.0);
        //cout<<ans<<endl;
        if(n>=ans) puts("T");
        else puts("F");
    }
    return 0;
}
/**
20 100
**/



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值