2016 ACM/ICPC Asia Regional Dalian Online 1006 football game 1007 hdu 5873 hdu 5874

Football Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3505    Accepted Submission(s): 655


Problem Description
A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced. 
  
  At the first phase of the championships, teams are divided into  M  groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
 

Input
Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers  M , which is the number of groups.
  The  i -th of the next  M  lines begins with a positive integer  Bi  representing the number of teams in the  i -th group, followed by  Bi  nonnegative integers representing the score of each team in this group.


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
 

Output
For each test case, output  M  lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
 

Sample Input
  
  
2 3 0 5 1 2 1 1
 

Sample Output
  
  
F T
#include <queue>
#include <vector>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
int main()
{
    ll n,m,x;
    ll sum;
    int flag;
    while(scanf("%I64d",&n) != EOF)
    {
        for(ll i =1;i <= n; i++)
        {
            scanf("%I64d",&m);
            flag = 1,sum = 0;
            for(ll j = 0; j < m; j++)
            {
                scanf("%I64d",&x);
                sum += x;
                if(x > 2*(m-1))
                    flag = 0;
            }
            if(sum != m*(m-1))
                flag = 0;
            if(flag)
                printf("T\n");
            else
                printf("F\n");
        }
    }
    return 0;
}

另外,贴一份1007的代码供参考:。。。。。。玄学举例。。
#include <iostream>
#include <cstdio>

using namespace std;

long long fun(int m)
{
    long long ans;
    ans = (m/2)*(m/2);
    if(m%2)ans += (m/2);
    return ans;
}

int main()
{
    long long n, m, res;
    while(scanf("%lld%lld", &m, &n)!=EOF)
    {
        res = fun(m);
        if(n>=res)
          printf("T\n");
        else printf("F\n");
    }

    return 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值