HDU 5878-I Count Two Three(可被2 3 5 7整除的数)

25 篇文章 1 订阅

I Count Two Three

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3582    Accepted Submission(s): 1094


Problem Description
I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It's interesting that the i -th attacks failed if and only if i can be rewritten as the form of 2a3b5c7d which a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d "I Count Two Three Numbers".
A related board game with a given positive integer n from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n .
 

Input
The first line of input contains an integer t(1t500000) , the number of test cases. t test cases follow. Each test case provides one integer n (1n109) .
 

Output
For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than  .
 

Sample Input
  
  
10 1 11 13 123 1234 12345 123456 1234567 12345678 123456789
 

Sample Output
  
  
1 12 14 125 1250 12348 123480 1234800 12348000 123480000
 

题目意思:

求出一个最小的不小于N的可被2 3 5 7整除的数。

解题思路:

打表二分搜索,注意表的范围不能开得太大也不能开得太小。

#include<cstdio>
#include<iostream>
#include<vector>
#include<cmath>
#include<cstring>
#include<queue>
#include<algorithm>
#include<set>
#include<queue>
#define N 10000
using namespace std;
const int maxn=200000*5;
typedef long long ll;
#define INF 0xfffffff
ll u[N];
ll getmin(ll a,ll b)
{
    return a<b?a:b;
}
void judge(int n)
{
    u[0]=1;
    int i2=0,i3=0,i5=0,i7=0;
    int i=1;
    while(i<n)
    {
        ll value=getmin(u[i2]*2,getmin(u[i3]*3,getmin(u[i5]*5,u[i7]*7)));
        if(value==u[i2]*2)
            ++i2;
        if(value==u[i3]*3)
            ++i3;
        if(value==u[i5]*5)
            ++i5;
        if(value==u[i7]*7)
            ++i7;
        u[i++]=value;
    }
    //return u[n-1];
}
int my_lower_bound(ll num)
{
    int l=0;
    int h=N-1;
    while(l<=h)
    {
        int mid=(l+h)/2;
        if(num>=u[mid])
            l=mid+1;
        else
            h=mid-1;
    }
    return l;
}
int main()
{
    judge(N);
    int t;
    ll n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        int tmp=lower_bound(u,u+N-1,n)-u;
        printf("%I64d\n",u[tmp]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值