HDU 5973-Game of Taking Stones(威佐夫博弈-JAVA BigDecimal)

15 篇文章 0 订阅

Game of Taking Stones

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 459    Accepted Submission(s): 176


Problem Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?
 

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
 

Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
 

Sample Input
  
  
2 1 8 4 4 7
 

Sample Output
  
  
0 1 0
 

Source

威佐夫博弈的裸题,就是咳咳咳…数据量巨大,JAVA BigDecimal 可搞。

 要精确到小数点后100位,精度要求太高了∑(っ °Д °;)っ

这个黄金分割数×(b-a)后如果等于a,那么为0,否则为1。(默认a<b)


import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main
{

    public static BigDecimal setScaleRoundDown(int newScale, BigDecimal b)
    {
        return b.setScale(newScale, BigDecimal.ROUND_DOWN);
    }

    public static void main(String[] args)
    {
        Scanner cin=new Scanner(System.in);
        BigDecimal a,b,tmp,yi,er,x,tp,l;
        while(cin.hasNextBigDecimal())
        {
            a=cin.nextBigDecimal();
            b=cin.nextBigDecimal();
            l= new BigDecimal(String.valueOf("0"));
            if(a.compareTo(l)==0)
            {
                if(b.compareTo(l)==0)
                {
                    System.out.println("0");
                    continue;
                }
            }
            if(a.compareTo(b)==0)
            {
                System.out.println("1");
                continue;
            }
            if(a.compareTo(b)>0)
            {
                tp=a;
                a=b;
                b=tp;
            }
            x=b.subtract(a);
            tmp = new BigDecimal(String.valueOf("1.61803398874989484820458683436563811772030917980576286213544862270526046281890244970720720418939113748475408807"));
            tmp=tmp.multiply(x);
            //System.out.println(tmp);
            //tmp.setScale(0,BigDecimal.ROUND_DOWN);
            //System.out.println(setScaleRoundDown(0, tmp));
            if(setScaleRoundDown(0, tmp).compareTo((a))==0)
                System.out.println("0");
            else
            {
                System.out.println("1");
            }
        }
    }
}

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值