ACM——Rightmost Digit

有技巧的大数计算

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6131 Accepted Submission(s): 1604
 
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6


      
      
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
Author
Ignatius.L
题意:

n^n

解法一:模拟大数乘法

由于数有奇偶的区别,所以这个是大数问题吧,不过数据太大一定有技巧的,n^n(n<=1000000000),题目要取的是个位数字,所以我们只有把(n)^n就可以了,因为进位对个位不影响,对于n的次方还是很大,我们就先求n/2,可是还是要考虑到n为奇数的时候t=t*t*a,(a=n);比如当n=5的时候n/2=2,t=(a^2)*(a^2)*(a)=a^5,但a^4即n=4;n/2=2;此时t=(a^2)*(a^2)

优化:

#include <stdio.h>
int pow(int n,int k)
{
    int rec=1;
    while(k)//k为次数
    {
        if(n>=10)n%=10;//不断缩小范围,防止溢出
        if(k%2)
        {
            rec*=n;
            if(rec>=10)rec%=10;//取尾数
        }
        n*=n;
        if(n>=10)n%=10;
        k/=2;
    }
    return rec;
}

int main()
{
    int n;
     scanf("%d",&n);
     while(n--){
       int a;
       scanf("%d",&a);
       printf("%d\n",pow(a,a));//n^n的模拟
     }
     return 0;
}

解法二:

#include<stdio.h>
int main(void)
{
long n;
int a[10][4]={{0},{1},{6,2,4,8},{1,3,9,7},{6,4},{5},{6},{1,7,9,3},{6,8,4,2},{1,9}},d,num;
scanf("%d",&num);
while(num--)
{
   scanf("%ld",&n);
   d=n;
   if(d==0||d==1||d==5||d==6)
    printf("%d\n",d);
   else if(d==4||d==9)
    printf("%d\n",a[d][n%2]);
   else if(d==2||d==3||d==7||d==8)
    printf("%d\n",a[d][n%4]);
}
return 0;
}
解法三:
可以发现一个规律:
当    n=  1 2 3 4 5 6 7 8 9  10 11 12 1314 15 16 17 18 19 20  21 22 23 24 25 27 28 29 3031  ...
rdigit =  1 4 7 6 5 6 36 9  0   1   3   6   6       4   7   5   6   6 9       ...
所以是以20为周期的规律。
#include<stdio.h>
int  rdigit[25] = {0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
int main ()
 {
    int cas , n ;
    scanf ( "%d" , &cas ) ;
    while ( cas -- )
    {
        scanf ( "%d" , &n ) ;
        printf ( "%d\n" , rdigit[n%20] ) ;
    }
    return 0 ;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值