杭电科大ACM:Rightmost Digit

Rightmost Digit

Problem Description

Given a positive integer N, you should output the most right digit of N^N.
给定一个正整数 N,你应该输出 N^N 中最右边的数字。

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
输入包含几个测试用例。 输入的第一行是一个整数 T,它是测试用例的数量。 T测试用例如下。
每个测试用例包含一个正整数 N(1<=N<=1,000,000,000)。

Output

For each test case, you should output the rightmost digit of N^N.
对于每个测试用例,您应该输出 N^N 最右边的数字。

Sample Input

2
3
4

Sample Output

7
6

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
在第一种情况下,3 * 3 * 3 = 27,所以最右边的数字是 7。
在第二种情况下,4 * 4 * 4 * 4 = 256,所以最右边的数字是 6。

#include<stdio.h>
typedef long long ll;
ll mod=1e5;
ll pow(ll a,ll b){
ll ans=1;while(b!=0){
if(b%2==1){
ans=ansa%mod;
}
a=a
a%mod;
b=b/2;
}
return ans;
}
int main(){
ll n,m,ans;
while(~scanf("%lld",&n)){
while(n–){
scanf("%lld",&m);
ans=pow(m,m)%10;
printf("%lld\n",ans);
}
}
return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值