[POJ]2406Power Strings KMP

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 49390 Accepted: 20575

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

跳next即可,n-nxt[n]一定是最小的循环节,若n不能整除它,那么就是1,有扩展欧几里得可得没必要从n跳前面的nxt.

#include<stdio.h>
#include<cstring>
using namespace std;
char s[1000005];
int nxt[1000005],lens;
inline void init(){
	nxt[0]=-1;int i=0,j=-1;
    lens=strlen(s);
    while(i<lens){
        if(s[i]==s[j]||j==-1) i++,j++,nxt[i]=j;
		else j=nxt[j];
	}
}
int main(){
    while(scanf("%s",s)){
    	if(s[0]=='.') break;
        init();
        if(!(lens%(lens-nxt[lens]))) printf("%d\n",lens/(lens-nxt[lens]));
        else puts("1");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值