POJ 2406 Power Strings 求最小循环节数(KMP)

Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 49380 Accepted: 20571
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input

abcd
aaaa
ababab
.
Sample Output

1
4
3
Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路:
简单题贴个链接

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int N = 1000005;

int nxt[N];
char s[N];
int len;

void calcnext() {
    int i = 0, j = -1;
    nxt[0] = -1;
    while(i < len) {
        if(j == -1 || s[i] == s[j]) {
            i++, j++;
            nxt[i] = j;
        }
        else
            j = nxt[j];
    }
}


int main(){
    while( scanf("%s", s) > 0 ){
        if( s[0] == '.' ) break;
        len = strlen(s);
        calcnext();
        if( len % ( len - nxt[len] ) == 0 )
            printf("%d\n", len / (len - nxt[len]));
        else
            printf("1\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值