POJ_2503 Babelfish解题报告.

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 22699 Accepted: 9742

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.
算法类型:qsort&二分
解题思路;先把字典储存下来,再进行字典序排序,在进行二分查找。
算法实现:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
# define MAX 100003
typedef struct dictionary    //用来储存字典的结构体;
{
	char f[20];
	char n[20];
}D;
D dic[MAX];
int cmp(const void *_p,const void *_q)/* 按照单词的字典序升序排序 */     //qsort字符串排序;
{
    D *q = (D *)_q;
    D *p = (D *)_p;
	return strcmp(p->n,q->n);
}
int main()
{
	char word[30];
	int i=0;
	while(gets(word)!=NULL)
	{
		if(word[0]=='\0')
			break;
		sscanf(word,"%s%s",dic[i].f,dic[i].n);    //用sscanf读入;
		i++;
	}
	qsort(dic,i,sizeof(dic[0]),cmp);
	while(gets(word)!=NULL)
	{
	  int low,mid,high;
	  low=0,high=i;
	  while(low<high)     //二分查找;
	  {
		  mid=(low+high)/2;
		  if(strcmp(dic[mid].n,word)==0)
		  {
			  printf("%s\n",dic[mid].f);
			  break;
		  }
		  if(strcmp(dic[mid].n,word)>0)
		  {
             high=mid;
		  }
		  else
		  {         
               low=mid+1;
		  }
	  }
	  if(low>=high)
	  {
		   printf( "eh\n");
	  }
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值