R - Babelfish
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input dog ogday cat atcay pig igpay froot ootfray loops oopslay atcay ittenkay oopslay Sample Output cat eh loops Hint
Huge input and output,scanf and printf are recommended.
|
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<string.h>
using namespace std;
const int MAX= 260050;
const int branchNum= 26;
struct TriedNode
{
char re[12];
TriedNode *branch[branchNum];
};
TriedNode root ;
TriedNode node [MAX];
int p=0;
void Initial()
{
memset((void*)node ,0,sizeof(node));
}
void Insert(char *word,char *re)
{
if(NULL==word)
{
return ;
}
TriedNode *location=&root;
while(*word)
{
if(NULL==location->branch[*word-'a'])
{
location->branch[*word-'a']=&node [p++];
}
location=location->branch[*word-'a'];
++word;
}
strcpy(location->re,re);
}
void Search(char*res,char *word)
{
if(NULL==word)
{
return ;
}
TriedNode *location=&root;
while(*word)
{
if(location->branch[*word-'a'])
{
location=location->branch[*word-'a'];
}
else
{
strcpy(res,"eh");
return ;
}
word++;
}
strcpy(res,location->re);
}
int main()
{
char word[12];
char eng[12];
char res[12];
char ch='\0';
Initial();
while(scanf("%s%s",eng,word)!=EOF)
{
Insert(word,eng);
getchar();
ch=getchar();
if('\n'!=ch)
{
ungetc(ch,stdin);
continue;
}
break;
}
while(scanf("%s",word)!=EOF)
{
Search(res,word);
printf("%s\n",res);
}
return 0;