poj 3620 Avoid The Lakes

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4


题意:John有一个农场被水淹了,可以获得保险公司的一些赔偿,但是是有条件的,赔偿数目取决于被淹的农场中最大的水洼大小。John的农场是个矩形,由一个个的小方格组成,输入中 N行, M列, K个被淹的方格。所以可能有多个水洼,而每个水洼可以由多个小方格构成(小方格之间必须是边连着的,不能是角相连),找出包含最多被淹的小方格的水洼。

思路:采用BFS搜索

#include <iostream>
#include <queue>
#include <string.h>
using namespace std;
struct node
{
    int x,y;
};
int map1[105][105];    //构建农场
int N,M,K;
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};  //搜索时要 上下左右 四个方向搜索
int BFS(int x1,int y1,int step)  //step代表该水洼有几个被淹的方格
{
    map1[x1][y1]=-1;  //访问过的就不在访问,设值为-1
    queue<node> Q;
    node p,s;
    p.x=x1; p.y=y1;
    Q.push(p);    //将起点压入队列
    while(!Q.empty())
    {
        p=Q.front();
        for(int i=0;i<4;i++)
        {
            x1=p.x+dir[i][0];y1=p.y+dir[i][1];
            if(x1>=1&&x1<=N&&y1>=1&&y1<=M&&map1[x1][y1]==0)
            {
                map1[x1][y1]=-1;
                s.x=x1;s.y=y1;
                Q.push(s);
                step++;
            }
        }
        Q.pop();
    }
    return step;
}
int main()
{
    int i,j;
    cin>>N>>M>>K;  //输入N行M列K个被淹地的坐标
    memset(map1,-1,sizeof(map1));  //农场全赋为-1,表示没淹
    for(i=0;i<K;i++)   //输入k个坐标
    {
        int R,C;
        cin>>R>>C;
        map1[R][C]=0;   //被淹的方格赋值为0
    }
    int mins=0;  
    for(i=1;i<=N;i++)
      for(j=1;j<=M;j++)
        if(map1[i][j]==0)
        {
            int m=BFS(i,j,1);  //传递坐标
            if(m>mins)
                mins=m;
        }
    cout<<mins<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值