LightOJ - 1021 :Painful Bases

As you know that sometimes base conversion is a painful task. But still there are interesting facts in bases.

For convenience let's assume that we are dealing with the bases from 2 to 16. The valid symbols are 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E and F. And you can assume that all the numbers given in this problem are valid. For example 67AB is not a valid number of base 11, since the allowed digits for base 11 are 0 to A.

Now in this problem you are given a base, an integer K and a valid number in the base which contains distinct digits. You have to find the number of permutations of the given number which are divisible by KK is given in decimal.

For this problem, you can assume that numbers with leading zeroes are allowed. So, 096 is a valid integer.

Input
Input starts with an integer  T (≤ 100), denoting the number of test cases.Each case starts with a blank line. After that there will be two integers,  base (2 ≤ base ≤ 16) and  K (1 ≤ K ≤ 20). The next line contains a valid integer in that base which contains distinct digits, that means in that number no digit occurs more than once.
Output
For each case, print the case number and the desired result.
Sample Input 3
2 2 10
10 2 5681
16 1 ABCDEF0123456789
Sample Output
Case 1: 1 Case 2: 12 Case 3: 20922789888000

思路:状压DP。用d[i][k]表示在i这个状态,余数为k的排列有多少种。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long d[1<<16][21];
char s[20];
int base,mod;
long long getsum(int i,int j)
{
	int th=0;
	while(i)th+=i%2,i/=2;
	long long sum=1;
	for(i=0;i<th;i++)
	{
		sum*=base;
		sum%=mod;
	}
	if(s[j]>='0'&&s[j]<='9')return (sum*(s[j]-'0'))%mod;
	return (sum*(s[j]-'A'+10))%mod;
}
int main()
{
	int T,n,cas=1;cin>>T;
	while(T--)
	{
		cin>>base>>mod;
		scanf("%s",s);
		n=strlen(s);
		memset(d,0,sizeof d);
		d[0][0]=1;
		for(int i=0;i<(1<<n);i++)
		{
			for(int j=0;j<n;j++)
			{
				if(i&(1<<j))continue;
				long long sum=getsum(i,j); //求出j加到当前状态的值
				for(int k=0;k<mod;k++)d[i|(1<<j)][(k+sum)%mod]+=d[i][k];
			}
		}
		printf("Case %d: %lld\n",cas++,d[(1<<n)-1][0]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值