练习三1024

Problem X

Time Limit : 2000/1000ms (Java/Other)   Memory Limit :131072/65536K (Java/Other)

Total Submission(s) : 16   Accepted Submission(s) : 10

Problem Description

Recently, iSeawent to an ancient country. For such a long time, it was the most wealthy andpowerful kingdom in the world. As a result, the people in this country arestill very proud even if their nation hasn’t been so wealthy any more.

The merchants werethe most typical, each of them only sold exactly one item, the price was Pi,but they would refuse to make a trade with you if your money were less than Qi,and iSea evaluated every item a value Vi.

If he had M unitsof money, what’s the maximum value iSea could get?

 

 

Input

There are severaltest cases in the input.

 

Each test casebegin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’number and the initial money.

Then N linesfollow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤Vi ≤ 1000), their meaning is in the description.

 

The inputterminates by end of file marker.

 

 

Output

For each testcase, output one integer, indicating maximum value iSea could get. 

 

Sample Input

2 10

10 15 10

5 10 5

3 10

5 10 5

3 5 6

2 7 3

 

 

Sample Output

5

11

 

 

题意:买东西,每个东西有三个特征值,p代表价格,q代表你手中钱必须不低于q才能买这个物品,v代表得到的价值。

 

解题思路:又是变种01背包,这题因为涉及到q,所以不能直接就01背包了。因为如果一个物品是5 9,一个物品是5 6,对第一个进行背包的时候只有dp[9],dp[10],…,dp[m],再对第二个进行背包的时候,如果是普通的,应该会借用前面的dp[8],dp[7]之类的,但是现在这些值都是0,所以会导致结果出错。于是要想到只有后面要用的值前面都可以得到,那么才不会出错。设A:p1,q1 B:p2,q2,如果先A后B,则至少需要p1+q2的容量,如果先B后A,至少需要p2+q1的容量,那么就是p1+q2 > p2+q1,变形之后就是q1-p1 < q2-p2。

 

 

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <map>
#define LL long long

using namespace std;

typedef struct
{
    int p,q,v;
}item;

const int N = 510;
const int M = 5010;
int n,m;
item t[N];
int dp[M];

void zero_dp(int i)
{
    for(int j = m; j >= t[i].p && j >= t[i].q; j--)
        dp[j] = max(dp[j], dp[j-t[i].p]+t[i].v);
}

int cmp(const void *a, const void *b)
{
    item *aa = (item *)a, *bb = (item *)b;
    return (aa->q-aa->p) - (bb->q-bb->p);
}

int main()
{
    int i,j,k;
    while(~scanf("%d%d", &n, &m))
    {
        for(i = 0; i < n; i++)
        {
            scanf("%d%d%d", &t[i].p, &t[i].q, &t[i].v);
            if(t[i].q > m) i--,n--;
        }
        qsort(t, n, sizeof(t[0]), cmp);
        memset(dp, 0, sizeof(dp));
        for(i = 0; i < n; i++)
            zero_dp(i);
        printf("%d\n", dp[m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我可以为你介绍一下关于 Redis 和 RabbitMQ 的基本概念和用法,帮助你进行练习。 Redis 是一种开源的内存据结构存储系统,它支持多种据类型,包括字符串、哈希、列表、集合和有序集合等。Redis 可以用于缓存、消息队列、发布/订阅等多种场景,具有高性能、可扩展性和稳定性等优点。 RabbitMQ 是一个基于 AMQP(Advanced Message Queuing Protocol)协议的消息队列系统,它支持消息的发布/订阅、点对点通信等多种模式。RabbitMQ 可以用于任务分发、异步处理、日志处理等多种场景,具有高可用性、高可靠性和可扩展性等优点。 在实际应用中,Redis 和 RabbitMQ 经常被用来结合使用,以实现更高效和可靠的据处理和消息传递。 下面是一些关于 Redis 和 RabbitMQ 的练习题: 1. 使用 Redis 实现一个简单的计器,每次请求都能够自增1,并返回当前计器的值。 2. 使用 RabbitMQ 实现一个简单的消息队列,其中生产者每隔一段时间会向队列中发送一个消息,消费者会不断地从队列中取出消息并进行处理。 3. 使用 Redis 和 RabbitMQ 结合使用,实现一个简单的任务分发系统,其中生产者将任务据存储到 Redis 中,消费者从 Redis 中取出任务据并进行处理,处理完成后将结果发送到 RabbitMQ 中,最后由一个结果处理器进行统一的结果汇总和处理。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值