Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSea could get.
Sample Input
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
Sample Output
5 11
背包问题,这道题需要进行排序,q-p按从小到大排序,原因暂时还没弄明白~
代码如下:
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
struct item
{
int p,q,v;
}it[501];
bool cmp(item a,item b)
{
return a.q-a.p<b.q-b.p;
}
int main()
{
int n,m,i,j,dp[5001];
while(cin>>n>>m)
{
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++) cin>>it[i].p>>it[i].q>>it[i].v;
sort(it,it+n,cmp);
for(i=0;i<n;i++)
for(j=m;j>=it[i].q;j--)
dp[j]=max(dp[j],dp[j-it[i].p]+it[i].v);
cout<<dp[m]<<endl;
}
return 0;
}