POJ 3250 Bad Hair Day 算法学习:单调栈

Bad Hair Day
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18534 Accepted: 6266

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c 1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

题意:


有N只牛向右看,只能看到第一只比他高的牛之前的牛。问每头牛能看到的牛的总数是多少?


方法:单调栈

所谓单调栈,就是在每次押入一个元素之前,将栈中所有大于(小于)他的元素弹出栈,这样就保证栈有一定的大小顺序。


每次读入一只牛的高度,就将栈中比他矮的牛弹出,然后将这只牛压入栈。因为比他矮的牛将看不到他及其右边的牛。所以,此时栈的大小便是能看到当前牛的牛的只数。这时再将这只牛的身高压入栈中。


代码:

//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int Stack[800005],top;        //单调栈和栈顶指针
int main()
{
    int n,hi;
    long long cnt=0;      //答案需要用long long 表示
    scanf("%d",&n);
    for (int i=0;i<n;i++)
    {
        scanf("%d",&hi);
        while (top>0 && hi>=Stack[top])        //单调栈操作,题目要求高度大于才能看到,所以弹栈的条件应是hi>=Stack[top]
            top--;
        cnt+=top;
        Stack[++top]=hi;
    }
    printf("%lld\n",cnt);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值