1044. 火星数字(20)

1044. 火星数字(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

火星人是以13进制计数的:

  • 地球人的0被火星人称为tret。
  • 地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13

提交代

/*
先定义两个字符串数组将那些啥文存储起来
其他按题目意思模拟就可
注意:涉及一个函数atoi,将字符串转化为整数
strstr函数,在某个字符串里面查找一个字符串 
*/
#include <iostream>
using namespace std;
#include <string.h>
char d1[][10]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
char d2[][10]={"","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
char line[100];
int main()
{
  int n;
  while(cin>>n)
  {
    getchar();
    while(n--)
    {
      cin.getline(line,100);
      if(line[0]>='0'&&line[0]<='9')
      {
        int d=atoi(line);
        if (d>=13)
        {
          cout<<d2[d/13];
          if(d%13)
            cout<<" "<<d1[d%13];
                                    cout<<endl;
        }
        else
          cout<<d1[d%13]<<endl;
      }
      else
      {
        int d=0,i;
        for(i=1;i<=12;i++)
          if (strstr(line,d2[i]))
          {
            d=i*13;
            break;
          }
        for(i=0;i<=12;i++)
          if (strstr(line,d1[i]))
          {
            d+=i;
            break;
          }
        cout<<d<<endl;
      }
    }
  }
  return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值