PAT甲级.1044. Shopping in Mars (25)

题意

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M)3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
    Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

给出一个数字序列与一个数S,在数字序列序列中求出所有和值为S的连续子序列(区间下标左端点的先输出,左端点相同时右端点小的先输出)。若没有这样的序列,求出和值恰好大于S的子序列(即在所有和值大于S的子序列中和值最接近S)。

输入格式

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 … DN (Di<=103 for all i=1, …, N) which are the values of the diamonds. All the numbers in a line are separated by a space.

输出格式

For each test case, print “i-j” in a line for each pair of i <= j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output “i-j” for pairs of i <= j such that Di + … + Dj > M with (Di + … + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

输入样例1

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

输出样例1

1-5
4-6
7-8
11-11

输入样例2

5 13
2 4 5 7 9

输出样例2

2-4
4-5

PAT链接


思路

A[i]不是递增,但Sum[i](A[1]到A[i]的和值)是单调递增的。可以用二分法来寻找右端点。
同时用sumOfSubsequence记录与M最接近且不小于M的值。第一次遍历找sumOfSubsequence的值,第二次遍历根据sumOfSubsequence的值输出左右端点

代码

/**
* @tag     PAT_A_1044
* @authors R11happy (xushuai100@126.com)
* @date    2017-2-14 19:06-20:23
* @version 1.0
* @Language C++
* @Ranking  1165/1182
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100010;
int sum[maxn];

// // 返回[L,R)内,第一个大于等于x的位置
// int low_bound(int L, int R, int x)
// {
//     int left = L, right = R, mid;
//     while(left < right)
//     {
//         mid = left + (right - left)/2;
//         if(x <= sum[mid])    right = mid;
//         else left = mid + 1;
//     }
//     return left;
// }

int main(int argc, char const *argv[])
{
    int N, M;
    scanf("%d%d", &N, &M);
    int sumOfSubsequence = 100010;
    for(int i = 1; i<=N; i++)
    {
        scanf("%d", &sum[i]);
        sum[i] += sum[i-1];
    }
    int j;  //右边界下标;
    for(int i = 0; i<N; i++)    //遍历左边界
    {
        j = lower_bound(sum+i, sum+N, sum[i]+M)-sum;
        if(sum[j] - sum[i] == M)
        {
            sumOfSubsequence = M;
            break;
        }
        else if(sum[j] - sum[i] - M > 0 &&sum[j] - sum[i] < sumOfSubsequence)   sumOfSubsequence = sum[j] - sum[i];
    }
    for(int i = 0; i<N; i++)
    {
        j = lower_bound(sum+i, sum+N, sum[i]+M)-sum;
        if(sum[j] - sum[i] == sumOfSubsequence)
        {
            printf("%d-%d\n",i+1,j );
        }
    }

    return 0;
}

收获

1.输入的数组不是有序的,但sum很可能是单调函数,可考虑用二分法的lower_bound函数和upper_bound函数
2.调用STL的函数格式

j = lower_bound(sum+i, sum+N, sum[i]+M)-sum;

3.自己写的话,lower_bound是找第一个大于等于x的位置,

if(x <= sum[mid]) right = mid;

upper_bound是找第一个大于x的位置

if(x < sum[mid]) right = mid;
  1. 用二分法的关键字连续子序列单调第一个或最后一个满足某条件
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值