PAT甲级.1083. List Grades (25)

题目

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

输入格式

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

输出格式

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output “NONE” instead.

输入样例1

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

输出样例1

Mike CS991301
Mary EE990830
Joe Math990112

输入样例2

2
Jean AA980920 60
Ann CS01 80
90 95

输出样例2

NONE

PAT链接


思路

根据成绩,逆序排序。取成绩在grade1和grade2之间的,输出

代码

version1.0

/**
* @tag     PAT_A_1083
* @authors R11happy (xushuai100@126.com)
* @date    2017-2-8 18:06-18:40
* @version 1.0
* @Language C++
* @Ranking  855/1584
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;

struct Student
{
    char name[12];
    char id[12];
    int grade;
}stu[100010];


bool cmp(Student a, Student b)
{
    return a.grade > b.grade;
}

int main(int argc, char const *argv[])
{
    int N;
    int grade1, grade2;
    int low = -1, high = -1;
    scanf("%d", &N);
    for(int i = 0; i<N; i++)
    {
        scanf("%s %s %d", stu[i].name, stu[i].id, &stu[i].grade);
    }
    scanf("%d %d", &grade1, &grade2);
    sort(stu, stu+N, cmp);
    // // 找到下限
    // for(int i = N-1; i>=0; i--)  //注意是i>=0,一开始写i>0测试点2不过
    // {
    //     if(stu[i].grade >= grade1)
    //     {
    //         low = i;
    //         break;
    //     }
    // }
    // for(int i = 0; i<N; i++)
    // {
    //     if(stu[i].grade <= grade2)
    //     {
    //         high = i;
    //         break;
    //     }
    // }
    // if(low < high) printf("NONE\n");
    // else
    // {
    //     for(int i = high; i<=low; i++)
    //     {
    //         printf("%s %s\n", stu[i].name, stu[i].id);
    //     }
    // }
    int flag = 0;
    for(int i = 0; i<N; i++)
    {
        if(stu[i].grade >= grade1 && stu[i].grade <= grade2)
        {
            printf("%s %s\n",stu[i].name, stu[i].id );
            flag = 1;
        }
    }
    if(!flag)   printf("NONE\n");
    return 0;
}

version2.0

/**
* @tag     PAT_A_1083
* @authors R11happy (xushuai100@126.com)
* @date    2017-2-8 18:06-18:40
* @version 1.0
* @Language C++
* @Ranking  855/1584
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;

struct Student
{
    char name[12];
    char id[12];
    int grade;
}stu[100010];


bool cmp(Student a, Student b)
{
    return a.grade > b.grade;
}

int main(int argc, char const *argv[])
{
    int N;
    int grade1, grade2;
    int low = -1, high = -1;
    scanf("%d", &N);
    for(int i = 0; i<N; i++)
    {
        scanf("%s %s %d", stu[i].name, stu[i].id, &stu[i].grade);
    }
    scanf("%d %d", &grade1, &grade2);
    sort(stu, stu+N, cmp);
    // 找到下限
    for(int i = N-1; i>=0; i--)  //注意是i>=0,一开始写i>0测试点2不过
    {
        if(stu[i].grade >= grade1)
        {
            low = i;
            break;
        }
    }
    for(int i = 0; i<N; i++)
    {
        if(stu[i].grade <= grade2)
        {
            high = i;
            break;
        }
    }
    if(low < high) printf("NONE\n");
    else
    {
        for(int i = high; i<=low; i++)
        {
            printf("%s %s\n", stu[i].name, stu[i].id);
        }
    }
    // int flag = 0;
    // for(int i = 0; i<N; i++)
    // {
    //     if(stu[i].grade >= grade1 && stu[i].grade <= grade2)
    //     {
    //         printf("%s %s\n",stu[i].name, stu[i].id );
    //         flag = 1;
    //     }
    // }
    // if(!flag)   printf("NONE\n");
    return 0;
}

收获

不一定要把所有符合要求的都找出来再一次性输出,可以边筛选边输出。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值