PAT甲级.1096. Consecutive Factors (20)

题意

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

输入格式

Each input file contains one test case, which gives the integer N

输出格式

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format “factor[1]factor[2]…*factor[k]”, where the factors are listed in increasing order, and 1 is NOT included.

输入样例

630

输出样例

3
567

思路

i从2~sqr遍历,找以i为起点的最多的consecutive factors。然后不断更新index 和 maxlen

代码

/**
* @tag     PAT_A_1096
* @authors R11happy (xushuai100@126.com)
* @date    2017-2-19 14:32-15:12
* @version 1.0
* @Language C++
* @Ranking  1445/903
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long LL;

int main(int argc, char const *argv[])
{
    LL N;
    scanf("%lld", &N);
    int maxLen = 0;
    int index = 0;
    LL sqr = (LL)sqrt(1.0*N);
    for(int i = 2; i<=sqr; i++)
    {
        int curLen = 0;
        LL tmp = i;
        if(N % i == 0)
        {
            curLen++;
            for(int j = i+1; j<=sqr; j++)
            {
                tmp*=j;
                if(N % tmp==0) curLen++;
                else break;
            }
            if(curLen > maxLen)
            {
                index = i;
                maxLen = curLen;
            }
        }
    }
    if(maxLen == 0)
    {
        printf("1\n");
        printf("%lld\n",N );
    }
    else
    {
        printf("%d\n",maxLen );
        for(int i = 0; i<maxLen-1; i++)
        {
            printf("%d*", index+i);
        }
        printf("%d\n",index+maxLen-1 );
    }

    return 0;
}

收获

如果factor不要求为prime,就不用套

struct Factor
{
    long long x;
    int cnt;
}fac[15];

的模板,直接遍历更新数值就好

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值