hdu 1050 Moving Tables

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35633    Accepted Submission(s): 11741


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30

解题思路1:统计重复次数最多的区间,因为重复次数最多的区间必定会最后完成。注意:将两行房间化为一行1、2其实为一个点,3、4也是一个点。因为1和2对门走廊不能同时用。

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

struct Node{
	int ss,ee;
}data[205];

int vi[205];
int n;
int cmp(Node a,Node b)
{
	return a.ss<b.ss;
}
int main()
{
	int t;
	int ans;
	scanf("%d",&t);
	while(t--)
	{
		ans=0;
		memset(vi,0,sizeof(vi));//初始化为零 
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&data[i].ss,&data[i].ee);
			if(data[i].ss>data[i].ee)	{
				int tem=data[i].ss; data[i].ss=data[i].ee; data[i].ee=tem;
			}
			data[i].ss=(data[i].ss+1)/2;	//将两行化为一行 
			data[i].ee=(data[i].ee+1)/2;
		}
		for(int i=0;i<n;i++)
		{
			for(int j=data[i].ss;j<=data[i].ee;j++)
			{
				vi[j]++;	//区间重复次数不断++,并记录最大值。 
				if(vi[j]>ans)
					ans=vi[j];
			}
		}
		printf("%d\n",ans*10);
	}
	
	return 0;
}

思路二:

将房间化为一行后,按左边界排序,从第一个开始,从左至右扫一遍,每次走完不冲突的区间,并标记,直到全部标记完。

记录一下一共扫了几遍。


本思路无代码实现,但确实可行。




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值