poj 1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 87187 Accepted: 19540

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

思路详见代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n;
double d;
double data[1005][2];
struct Node{
	double l,r;
}dir[1005];

int cmp(Node a,Node b)
{
	return a.l<b.l;
}

int cal()	//计算能扫到每个岛的区间
{
	int index=0;
	for(int i=0;i<n;i++)
	{
		if(data[i][1]>d)	//有一个岛屿扫不到,结果直接 -1
			return 0;
		double dis=sqrt(d*d-data[i][1]*data[i][1]);
		dir[index].l=data[i][0]-dis;
		dir[index].r=data[i][0]+dis;
		index++;
	}
}

int main()
{
	int cc=0;
	int ans;
	while(scanf("%d%lf",&n,&d),n+d)
	{
		ans=0;
		for(int i=0;i<n;i++)
			scanf("%lf%lf",&data[i][0],&data[i][1]);
		if(cal())
		{
			sort(dir,dir+n,cmp);
			double ll,rr;
			ll=dir[0].l;	rr=dir[0].r;
			for(int i=1;i<n;i++)	//对所求的区间做交集,最后看看有几个不交叉的集合,就是几个雷达。 
			{
				if(dir[i].l>rr)
				{
					ll=dir[i].l;	//注意比较对象的改变 
					rr=dir[i].r;
					ans++;
				}
				else if(dir[i].l<=rr)
				{
					ll=dir[i].l;
					if(dir[i].r<=rr) 
						rr=dir[i].r;
				}
			}
			printf("Case %d: %d\n",++cc,++ans);
		}
		else
		{
			printf("Case %d: -1\n",++cc);
		} 
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值