HDU - 1003 Max Sum(经典dp/尺取法)

142 篇文章 3 订阅
23 篇文章 0 订阅

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

题意:求和最大的最长连续子序列

解题思路:
1.尺取法:
尺取法应该注意判断顺序!
从第一位开始累加,当和为负数时放弃这一段从下一位重新开始累加(因为当前n项和为负数时对后面的累加没有贡献),用一个变量记录下每次累加的最大值,并在每次更新最大值的同时更新起点与终点下标。

#include<stdio.h>

int main()
{
    int t,n,tt=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        //尺取法 
        int maxx=-1001,sum=0,l=1,left,right,x;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            sum+=x;
            if(sum>maxx)
            {
                maxx=sum;
                left=l;//更新起点 
                right=i;//更新终点 
            }
            if(sum<0)//顺序不能反,考虑如果一组数全是负数 
            {
                sum=0;//如果当前的累加和已经小于0则抛弃这一段重新开始 
                l=i+1;
            }
        }
        printf("Case %d:\n",tt++);
        printf("%d %d %d\n",maxx,left,right);
        if(t) printf("\n");
    }
    return 0;
}

2.dp:
http://www.cnblogs.com/tommychok/p/5199668.html
解题思路:经典DP,可以定义dp[i]表示以a[i]为结尾的子序列的和的最大值,因而最大连续子序列及为dp数组中的最大值。
状态转移方程:
dp[1] = a[1]; //以a[1]为结尾的子序列只有a[1];

i >= 2时, dp[i] = max( dp[i-1]+a[i], a[i] );

dp[i-1]+a[i] > a[i]时,即dpi-1的值为正,那么dp[i-1]则对dp[i]有贡献,

dp[i-1]+a[i] < a[i]时,即dp[i-1] < 0,那么抛弃它,dp[i] = a[i]

//http://www.cnblogs.com/tommychok/p/5199668.html 
#include<stdio.h>

int dp[100010];

int main()
{
    int t,n,tt=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&dp[i]);
        }
        int maxx=dp[1],left=1,right=1,l=1;//下标必须初始化 
        for(int i=2;i<=n;i++)
        {
            if(dp[i-1]<0)//如果前i-1项的和小于0则舍弃这一段从i重新开始 
            {
                l=i; //不对数组的值有影响,只是记录输出的起点下标
            }
            else
            {
                dp[i]=dp[i-1]+dp[i];//只有当前i-1的和不为0时才更新i的值
            }
            if(dp[i]>maxx)
            {
                maxx=dp[i];
                left=l;
                right=i;
            }
        }
        printf("Case %d:\n",tt++);
        printf("%d %d %d\n",maxx,left,right);
        if(t) printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值