HDU-1003 Max Sum (线性dp 最大连续和)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 261011    Accepted Submission(s): 62054


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6


#include <bits/stdc++.h>
using namespace std;
int dp[100001], a[100001], pre[100001];
int main(){
	int T, n, l, r, casenum = 1;
	scanf("%d", &T);
	while(T--){
		scanf("%d", &n);
		for(int i = 1; i <= n; ++i){
			scanf("%d", &a[i]);
		}
		memset(dp, 0, sizeof(dp));
		memset(pre, 0, sizeof(pre));
		int ans = -1e9;
		for(int i = 1; i <= n; ++i){
			pre[i] = pre[i - 1] + a[i];
			dp[i] = max(a[i], dp[i - 1] + a[i]);
			ans = max(ans, dp[i]);
		}
		for(int i = 1; i <= n; ++i){
			if(dp[i] == ans){
				r = i;
				break;
			}
		}
		for(int i = 1; i <= n; ++i){
			if(pre[r] - pre[i - 1] == ans){
				l = i;
				break;
			}
		}
		printf("Case %d:\n%d %d %d\n", casenum++, ans, l, r);
		if(T){
			puts("");
		}
	}
}

/*
题意:
100000个数,求最大连续和并且输出方案,要求输出的区间两端点最小.。

思路:
线性dp,dp[i]表示以第i个数结尾的最大连续和。转移方程:dp[i] = max(a[i], dp[i - 1] + a[i]);
输出方案时枚举端点即可。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值