SGU 154 Factorial(数论+二分)

81 篇文章 0 订阅
49 篇文章 0 订阅

Description
求最小的整数n使得n!的值后面有q个0
Input
一个整数q(0<=q<=10^8)
Output
满足条件的最小的正整数n,如果不存在则输出No solution
Sample Input
2
Sample Output
10
Solution
n!后面0的个数等于n!的质因子分解形式中5的幂指数,即为[n/5]+[[n/5]/5]+…,所以n最多为5*10^8,二分n即可
Code

#include<cstdio>
#include<iostream>
using namespace std;
#define maxn 11111
#define INF 0x3f3f3f3f
int count(int n)
{
    int ans=0;
    while(n)
    {
        ans+=n/5;
        n/=5;
    }
    return ans;
}
void solve(int n)
{
    int l=0,r=INF;
    while(l<=r)
    {
        int mid=(l+r)>>1;
        int temp=count(mid);
        if(temp>=n)r=mid-1;
        else if(temp<n)l=mid+1;
    }
    if(count(l)==n)printf("%d\n",l);
    else printf("No solution\n");
}
int main()
{
    int n;
    scanf("%d",&n);
    if(n==0)printf("1\n");
    else solve(n);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值