HDU 1227 Fast Food

Fast Food

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1467    Accepted Submission(s): 635


Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.  

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.  

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.  
 

Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.  
 

Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.  

Output a blank line after each test case.
 

Sample Input
  
  
6 3 5 6 12 19 20 27 0 0
 

Sample Output
  
  
Chain 1 Total distance sum = 8
 
思路:cost[i][j] i到j之间只有一个仓库时的最优路径长。dp[i][j]前j个店设有i个补给站的最优值。

dp[i][j]=MIN(dp[i][j],dp[i-1][m]+cost[m+1][j])..

 

AC代码:

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;

int MIN(int a,int b)
{
    return a<b?a:b;
}
int main()
{
    int dp[35][210];
    int loc[210],cost[210][210];
    int n,k,c=0;
    while(cin>>n>>k)
    {
        if(!n&&!k)
        break;
        c++;
        for(int i=1;i<=n;i++)
        cin>>loc[i];
        for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
        {cost[i][j]=0;
         for(int m=i;m<=j;m++)
         cost[i][j]+=fabs(loc[m]-loc[(i+j)/2]);
        }

        for(int i=1;i<=n;i++)       //边界
        dp[1][i]=cost[1][i];

        for(int i=2;i<=k;i++)          //仓库个数
       for(int j=i;j<=n;j++)          //商店个数
       {
        dp[i][j]=10000000;
        for(int m=i-1;m<j;m++)
        dp[i][j]=MIN(dp[i][j],dp[i-1][m]+cost[m+1][j]);
       }
       cout<<"Chain "<<c<<endl;
       cout<<"Total distance sum = "<<dp[k][n]<<endl;
       cout<<endl;
    }
    return 0;
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值