poj 1984 Navigation Nightmare(带权并查集)

18 篇文章 0 订阅
Navigation Nightmare
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 3304 Accepted: 1383
Case Time Limit: 1000MS

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n):
           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17
...

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1".

Input

* Line 1: Two space-separated integers: N and M



* Lines 2..M+1: Each line contains four space-separated entities, F1,

        F2, L, and D that describe a road. F1 and F2 are numbers of

        two farms connected by a road, L is its length, and D is a

        character that is either 'N', 'E', 'S', or 'W' giving the

        direction of the road from F1 to F2.



* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

        queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

        and contains three space-separated integers: F1, F2, and I. F1

        and F2 are numbers of the two farms in the query and I is the

        index (1 <= I <= M) in the data after which Bob asks the

        query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

        queries.  Each line should contain either a distance

        measurement or -1, if it is impossible to determine the

        appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.
 
题意:有n个农场,编号为1——n,农场之间以路径相连接,有m条路径,给出m条路径的描述,每条路径都描述为F1  F2  L  D,表示编号为F2的农场在F1的D方向上,且距离F1为L的长度,D可为‘E'、’W‘、’N‘、’S‘,分别代表东、西、北、南。然后给出k条询问,每条询问描述为F1  F2  I,表示给出了I条路径后F2与F1的Manhattan distance(two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2|),如果未知,则输出-1.
思路:类似食物链的带权并查集。每个结点设两个权值x,y。x表示相对于父节点的水平方向的偏移量,y表示相对于父节点的竖直方向的偏移量。在合并和路径压缩的时候更新就可以了。
 
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;
struct edge     //保存每条路
{
    int u,v;
    int len;
    char dir;
} road[40005];
struct node
{
    int fa;
    int x;   //相对于父节点的水平方向的偏移量
    int y;   //相对于父节点的竖直方向的偏移量
} farm[40005];
struct node1      //保存每个询问
{
    int u,v,line;
    int id;
} query[10005];
bool cmp(node1 a,node1 b)   //按询问的index排序
{
    return a.line<b.line;
}
int n,m,k;
int ans[10005];    //保存每个询问的结果

void init()        //初始化
{
    for(int i=1; i<=n; i++)
    {
        farm[i].fa=i;
        farm[i].x=0;
        farm[i].y=0;
    }
}
int Find_set(int a)
{
    int temp;
    if(a==farm[a].fa) return a;
    temp=farm[a].fa;
    farm[a].fa=Find_set(farm[a].fa);
    farm[a].x+=farm[temp].x;
    farm[a].y+=farm[temp].y;
    return farm[a].fa;
}
void Union(edge a)
{
    int ru=Find_set(a.u);
    int rv=Find_set(a.v);
    if(ru==rv) return;
    farm[rv].fa=ru;
    if(a.dir=='E')
    {
        farm[rv].x=farm[a.u].x-farm[a.v].x+a.len;    //偏移量更新:ru->rv=ru->u+u->v+v->rv,下面的相同
        farm[rv].y=farm[a.u].y-farm[a.v].y;
    }
    else if(a.dir=='W')
    {
        farm[rv].x=farm[a.u].x-farm[a.v].x-a.len;
        farm[rv].y=farm[a.u].y-farm[a.v].y;
    }
    else if(a.dir=='N')
    {
        farm[rv].x=farm[a.u].x-farm[a.v].x;
        farm[rv].y=farm[a.u].y-farm[a.v].y+a.len;
    }
    else
    {
        farm[rv].x=farm[a.u].x-farm[a.v].x;
        farm[rv].y=farm[a.u].y-farm[a.v].y-a.len;
    }
    return;
}
int main()
{
    cin>>n>>m;
    init();
    for(int i=1; i<=m; i++)
        cin>>road[i].u>>road[i].v>>road[i].len>>road[i].dir;
    cin>>k;
    for(int i=0; i<k; i++)
    {
        cin>>query[i].u>>query[i].v>>query[i].line;
        query[i].id=i;
    }
    sort(query,query+k,cmp);
    int cur=1;
    for(int i=0; i<k; i++)
    {
        while(cur<=query[i].line)
        {
            Union(road[cur++]);
        }
        if(Find_set(query[i].u)!=Find_set(query[i].v))
            ans[query[i].id]=-1;
        else
            ans[query[i].id]=abs(farm[query[i].u].x-farm[query[i].v].x)+abs(farm[query[i].u].y-farm[query[i].v].y);
    }
    for(int i=0; i<k; i++)
        cout<<ans[i]<<endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值