POJ 3621 最优比率生成环 二分求解

30 篇文章 0 订阅

Sightseeing Cows

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

Submit Status

Description

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the direction L1i -> L2i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input
  • Line 1: Two space-separated integers: L and P
  • Lines 2..L+1: Line i+1 contains a single one integer: Fi
  • Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L1i , L2i , and Ti
Output
  • Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.
Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00

求最优比率生成环。注意是有向图。
方法:二分
不妨设ans即为所求

ans=s[i]÷dis[i][j]

变形可得
ans×dis[i][j]s[i]=0

接下来二分查找ans就行了。

注意精度
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <queue>
using namespace std ;
const int maxn = 1010 ;
const int zhf = 1000000000 ;
struct node {
    int v, w ;
} ;
vector <node> g[maxn] ;
int n, m, s[maxn], cnt[maxn] ; //SPFA判环需要记录点出现次数
double d[maxn] ;
bool p[maxn] ;
bool spfa ( double ans ) {
    queue <int> q ;
    memset ( cnt, 0, sizeof(cnt) ) ;
    memset ( p, 0, sizeof(p) ) ;
    int i, j, k, u, v, w ;
    for ( i = 1 ; i <= n ; i ++ ) 
        d[i] = zhf * 1.0 ;
    p[1] = 1 ; d[1] = 0.0 ;
    q.push(1) ; 
    while ( !q.empty() ) {
        int u = q.front() ;
        p[u] = 0 ;
        q.pop() ;
        for ( i = 0 ; i < g[u].size() ; i ++ ) {
            v = g[u][i].v ;
            double wei = ans * g[u][i].w - s[v] * 1.0 ; //方程见上
            if ( d[v] > wei + d[u] ) {
                d[v] = wei + d[u] ;
                if ( !p[v] ) {
                    p[v] = 1 ;
                    if ( ++cnt[v] > n ) return true ;
                    q.push(v) ;
                }
            }
        }
    }
    return false ;
}
int main () {
    int i, j, k, u, v, w ;
    int sum = 0 ; 
    scanf ( "%d%d", &n, &m ) ;
    for ( i = 1 ; i <= n ; i ++ ) {
        scanf ( "%d", s + i ) ;
        sum += s[i] ;
    }
    for ( i = 1 ; i <= m ; i ++ ) {
        scanf ( "%d%d%d", &u, &v, &w ) ;
        g[u].push_back( (node) {v,w} ) ;
    }
    double mid, l = 0.0, r = sum * 1.0, ans ; 
    while ( (r-l) > 1e-3 ) { // 二分答案
        mid = ( r + l ) * 1.0 / 2 ;
        if ( spfa(mid) ) {
            l = mid ;
            ans = mid ;
        }
        else r = mid ;
    }
    printf ( "%.2f\n", ans ) ;
    return 0 ;
}

是不是很简单呢

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值