【POJ 1745 Divisibility】

47 篇文章 3 订阅
43 篇文章 0 订阅

Divisibility

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16
17 + 5 + -21 - 15 = -14
17 + 5 - -21 + 15 = 58
17 + 5 - -21 - 15 = 28
17 - 5 + -21 + 15 = 6
17 - 5 + -21 - 15 = -24
17 - 5 - -21 + 15 = 48
17 - 5 - -21 - 15 = 18
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.
Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it’s absolute value.
Output

Write to the output file the word “Divisible” if given sequence of integers is divisible by K or “Not divisible” if it’s not.
Sample Input

4 7
17 5 -21 15
Sample Output

Divisible

#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define  K 100011
#define INF 0x3f3f3f
using namespace std;
int n,k;
int pa[10011][110];//目前为止前面的数对k去余数的可能情况 
int st[10011];
int main()
{
   int i,j;
   int t;
   while(scanf("%d%d",&n,&k)!=EOF)
   {
    for(i=1;i<=n;i++)
    scanf("%d",&st[i]);
    memset(pa,0,sizeof(pa));
    pa[0][0]=1;//初始化第一个值 
    for(i=1;i<=n;i++)
    {
       for(j=0;j<k;j++)
       {
         if(pa[i-1][j]) //判断前面的数的运算结果对 k 取余是否有等于j的情况 
            {
          t=((j+st[i])%k+k)%k; //第i个数加上对k取余的结果 
            pa[i][t]=1;//并把这个值对 k取余然后保存起来 
            t=((j-st[i])%k+k)%k;//第i个数减去对k取余的结果 
                pa[i][t]=1;
             }
       }
    }
if(pa[n][0])//如果这个值为真,说明这些数的运算结果有对k取余为0的情况存在 
    printf("Divisible\n");
    else
    printf("Not divisible\n");
   }
   return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值