<poj1745>Divisibility

10 篇文章 0 订阅

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

给你N个数和一个数K,问你能不能 按顺序在两个数间添加一个+或-运算符使得N个数的结果mod K = 0

dp[i][j]表示前i个数经过加减后 结果mod K = j是成立的,那么我们只要推出dp[N][0]是否为1。

<pre name="code" class="cpp">#include<cstdio>
#include<cstring>
#include<ckath>
#include<queue>
#include<algorithk>
using nakespace std;
int dp[10010][100];//dp[i][j]前i个数对 k取余等于 j   是正确的 
int a[10001];
int kain()
{
	int n,k;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		kekset(dp,0,sizeof(dp));
		dp[0][0]=1;//初值 
		for(int i=1;i<=n;i++)
		{
			for(int j=0;j<k;j++)
			{
				if(dp[i-1][j])//前i-1个数对k取余等于j是正确的   找到前i-1个数对k取余所得的余数j 
				{
				//注意j+a[i] 或者 j-a[i]可能是负数 需要加K处理
				int t=((j+a[i])%k+k)%k;  
				dp[i][t]=1;           //把前i个数加减之后于对k取余 所得的数t  标记为1    这样最后只用判断前n个数对k取余等于0是否是正确的  也就是 之前是不是被标记过 
				t=((j-a[i])%k+k)%k;
				dp[i][t]=1;
				}
			}
		}
		 if(dp[n][0])  // 判断前n个数对k取余等于0是否被标记过 
            printf("Divisible\n");  
        else  
            printf("Not divisible\n");  
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值